HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Gbe2c communication problems

 
SOLVED
Go to solution
jcd_2
Frequent Advisor

Gbe2c communication problems

Dear,
I have a problem with my 2 Gbe2c in my HP C 7000.

Each switch is unable to ping the other.
Every blade (w2k3 or esx 3.0.1; NIC teaming is configured in active/active) is able to ping just one of the 2 switch.

It is a big problem for Virtual infrastructure.
For the moment, i only use half of my nics, the second gbe2c is not in use because of my problem.

I configure UFD to disable internal ports when my uplink 21 fail.


I flash it both to V2.0 (image and boot) with no better results.
Uplink to 2 core network HP on port 21 (or 21 and 22 in a cross configuration), but it still the same.
I enabled port 17 and 18 for trunk 1. These ports was disabled y default, strange ? and no more results.

What I' ve done bad ? where i fail ?
Thanks for your help.
3 REPLIES
HEM_2
Honored Contributor
Solution

Re: Gbe2c communication problems

I have seen this behavior before. It usually happens because of the way the GBE2c management interface connects to the Onboard Administrator instead of going out the standard uplinks.

It is normal behavior for the 2 gbe2cs in an enclosure to not be able to ping each other. This is just a function of how they connect to the Onboard Administrator in an out-of-band fashion.

When servers or external devices can't ping one of the gbe2c switches, it is usually due to that switch being the root for the network. When a switch is the root, it forwards BPDU's out every 2 seconds and uses the same MAC address as its source to send out the uplinks as the one used by the management IP (sent out the OA port). This causes a problem. You can view the spanning tree config on a gbe2c by issuing the following command:

/i/l2/stp

compare the current root MAC Address with the switch's MAC address from here:

/i/sys/gen

If they are the same, that is your problem.

3 ways to correct this:

1) ensure some other switch is the spanning tree root bridge of your network(s). Lowest STP Bridge Priority will become the root

2) Instead of using the management interfaces that connect to the OA (Interface 256), disable that interface and put your IP address on Interface 1 in the desired VLAN

3) Put the OA port in a VLAN that is not configured on the GBE2
jcd_2
Frequent Advisor

Re: Gbe2c communication problems

Thanks for you interest HEM.
Gbe2c's are not root bridge of RSTP. I verify with your commands and mac address are differents.
I'm using EBIPA (OA firmware 1.30) for configuring management IP of Gbe2c and it's true that is on interface 256 on VLAN 4095. :-/

I will try to configure static IP address on my Gbe2c on interface 1 VLAN 1.
It's difficult for us to change OA VLAN
jcd_2
Frequent Advisor

Re: Gbe2c communication problems

The results:
I have disabled UFD, keeping RSTP.
In each Gbe2c, I have disabled interface 256 that hold the IP configured through EBIPA in VLAN 4095.
I also disabled GW 4 to enable GW 1 but it don't work.
Then i put a static IP and GW in interface 1 (=> VLAN 1).


It seems to work fine without EBIPA !!
Thanks a lot for your help.