BladeSystem - General

Get-HPEOAServerInfo not getting the FLB info

 
JohnM1
Occasional Advisor

Get-HPEOAServerInfo not getting the FLB info

Hi i'm using the HPEOACmdlets v2.0

Running 
Get-HPEOAServerInfo , it's not returning the FLB adapter info fully.  I'm not getting any info about what the NIC model is installed.
it just returns
FLBAdapter : {@{EthernetFlexNICLOM11a=1-a D8:9D:67:73:CA:48; EthernetFlexNICLOM12a=2-a D8:9D:67:73:CA:4C; FLBAdapterNumber=1}}
 
What i'm expecting to see is
FLB Adapter 1: HP FlexFabric 20Gb 2-port 650FLB Adapter
 
Thanks
6 REPLIES 6
Kashyap02
HPE Pro

Re: Get-HPEOAServerInfo not getting the FLB info

I have tried the below commands using the HPEOACmdlets 2.0. It lists the FLB and Mezz details. 

1. Make a connection to the OA

 

$connection = Connect-HPEOA <OA IP> -Username "<OA Username>" -Password "<OA Password>"

 

2. create a variable as below

 

$serv = $connection | Get-HPEOAServerInfo -Bay <Bay Number>

 

3. $serv will give the details of the server in the bay which you mentioned above. 

 

4. But FLB and Mezz adapters details show as below. 

 

FLBAdapter=System.Management.Automation.PSObject[];
Mezzanine=System.Management.Automation.PSObject[];

 

5. Run the below command to get the object names. Notice that the FLB and the Mezzanine card names shows. 

 

$serv.ServerBlade

 

6. you can also specifically verify the details by using the below commands. 

 

$serv.ServerBlade.Mezzanine
$serv.ServerBlade.FLBAdapter

 

Hope this helps. 

I am a HPE Employee

Accept or Kudo

JohnM1
Occasional Advisor

Re: Get-HPEOAServerInfo not getting the FLB info

Hi, you lost me on your step 4, can you show an example please

 

I get this,

$serv


IP : 10.x.xx
Hostname :
StatusType : OK
StatusMessage : OK
ServerBlade : {@{Type=Server Blade; Manufacturer=HP; ProductName=ProLiant BL460c Gen8; PartNumber=666157-B21; SystemBoardSparePartNumber=654609-001;
SerialNumber=MXQxxxx; UUID=31363636-3735-584D-5133-313430384A36; ServerName=axxxx.com; AssetTag=[Unknown]; ROMVersion=I31
06/01/2015; CPU=System.Management.Automation.PSObject[]; Memory=229376 MB; FLBAdapter=System.Management.Automation.PSObject[];
Mezzanine=System.Management.Automation.PSObject[]; ManagementProcessorInformation=; Bay=1}}

 

 $serv.ServerBlade


Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c Gen8
PartNumber : 666157-B21
SystemBoardSparePartNumber : 654609-001
SerialNumber : Mxxx
UUID : 31363636-3735-584D-5133-313430384A36
ServerName : xxx.com
AssetTag : [Unknown]
ROMVersion : I31 06/01/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz (8 cores); CPUNumber=1}, @{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz
(8 cores); CPUNumber=2}}
Memory : 229376 MB
FLBAdapter : {@{EthernetFlexNICLOM11a=1-a D8:9D:67:73:CA:48; EthernetFlexNICLOM12a=2-a D8:9D:67:73:CA:4C; FLBAdapterNumber=1}}
Mezzanine : {@{CardName=HP LPe1205A 8Gb FC HBA for BladeSystem c-Class; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILOMXQ31408J6; FirmwareVersion=2.55 Aug 16 2017; IPAddress=x.x.x.x; MACAddress=6C:3B:E5:BF:E2:0D;
PowerManagementControllerVersion=3.3.0; iLOFederationCapable=Yes}
Bay : 1

 

 

 

Kashyap02
HPE Pro

Re: Get-HPEOAServerInfo not getting the FLB info

your output still shows 

FLBAdapter=System.Management.Automation.PSObject[];
Mezzanine=System.Management.Automation.PSObject[]

 

This is the output from my server. 

 

PS C:\Windows\system32> $serv.ServerBlade


Type                           : Server Blade
Manufacturer                   : HP
ProductName                    : ProLiant BL460c Gen9
PartNumber                     : 813198-B21
SystemBoardSparePartNumber     : 843305-001
SerialNumber                   : USXXXXXX
UUID                           : 31333138-3839-5355-4536-323036434B59
ServerName                     : BL460CG906CKY
AssetTag                       :
ROMVersion                     : I36 10/21/2019
BootMode                       : UEFI Optimized
SecureBoot                     : Disabled
CPU                            : {@{Value=Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz (8 cores); CPUNumber=1}, @{Value=Not present; CPUNumber=2}}
Memory                         : 16384 MB
FLBAdapter                     : {@{CardName=HP FlexFabric 20Gb 2-port 650FLB Adapter; EthernetNIC0LOM11a=1-a B0:5A:DA:BA:24:E0; ISCSIHBALOM11b=1-b B0:5A:DA:BA:24:E1; FCoEHBALOM11b=1-b 10:00:B0:5A:DA:BA:24:E1; EthernetNIC1LOM12a=2-a B0:5A:DA:BA:24:E8;
                                 ISCSIHBALOM12b=2-b B0:5A:DA:BA:24:E9; FCoEHBALOM12b=2-b 10:00:B0:5A:DA:BA:24:E9; FLBAdapterNumber=1}}
Mezzanine                      : {@{CardName=HP QMH2672 16Gb FC HBA for BladeSystem c-Class; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILOBL460CG906CKY; FirmwareVersion=2.72 Oct 20 2019; IPAddress=10.x.x.x; MACAddress=70:10:6F:50:22:00; PowerManagementControllerVersion=1.0.9; iLOFederationCapable=Yes}
ManagementProcessorIPv6        : @{LinkLocalAddress=fe80::7210:6fff:fe50:2200/64}
Bay                            : 1


PS C:\Windows\system32> $serv.ServerBlade.Mezzanine

CardName                                       Port                                                                                             MezzanineNumber
--------                                       ----                                                                                             ---------------
HP QMH2672 16Gb FC HBA for BladeSystem c-Class {@{Value=50:01:43:80:24:2d:7e:a0; PortNumber=1}, @{Value=50:01:43:80:24:2d:7e:a2; PortNumber=2}}               1

PS C:\Windows\system32> $serv.ServerBlade.FLBAdapter


CardName           : HP FlexFabric 20Gb 2-port 650FLB Adapter
EthernetNIC0LOM11a : 1-a B0:5A:DA:BA:24:E0
ISCSIHBALOM11b     : 1-b B0:5A:DA:BA:24:E1
FCoEHBALOM11b      : 1-b 10:00:B0:5A:DA:BA:24:E1
EthernetNIC1LOM12a : 2-a B0:5A:DA:BA:24:E8
ISCSIHBALOM12b     : 2-b B0:5A:DA:BA:24:E9
FCoEHBALOM12b      : 2-b 10:00:B0:5A:DA:BA:24:E9
FLBAdapterNumber   : 1

 

Try reinstalling the HPEOACmdlets and use the above commands again. 

 

 

I am a HPE Employee

Accept or Kudo

JohnM1
Occasional Advisor

Re: Get-HPEOAServerInfo not getting the FLB info

I installed the cmdlets on a different system, same result.

 

$serv.ServerBlade


Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c Gen8
PartNumber : 666157-B21
SystemBoardSparePartNumber : 654609-001
SerialNumber : xxx
UUID : 31363636-3735-584D-5133-313430384A36
ServerName : axx.com
AssetTag : [Unknown]
ROMVersion : I31 06/01/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz (8 cores); CPUNumber=1},
@{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz (8 cores); CPUNumber=2}}
Memory : 229376 MB
FLBAdapter : {@{EthernetFlexNICLOM11a=1-a D8:9D:67:73:CA:48; EthernetFlexNICLOM12a=2-a
D8:9D:67:73:CA:4C; FLBAdapterNumber=1}}
Mezzanine : {@{CardName=HP LPe1205A 8Gb FC HBA for BladeSystem c-Class;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILOxxxx; FirmwareVersion=2.55 Aug 16 2017;
IPAddress=10.1.1.1; MACAddress=6C:3B:E5:BF:E2:0D;
PowerManagementControllerVersion=3.3.0; iLOFederationCapable=Yes}
Bay : 1

BladeStatus : No Server Blade Installed
Bay : 2

BladeStatus : No Server Blade Installed
Bay : 3

BladeStatus : No Server Blade Installed
Bay : 4

BladeStatus : No Server Blade Installed
Bay : 5

BladeStatus : No Server Blade Installed
Bay : 6

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c Gen9
PartNumber : 813198-B21
SystemBoardSparePartNumber : 843305-001
SerialNumber : xxx
UUID : 31333138-3839-4D32-3236-353230343037
ServerName : xxx.com
AssetTag :
ROMVersion : I36 10/21/2019
BootMode : UEFI
SecureBoot : Disabled
CPU : {@{Value=Intel(R) Xeon(R) CPU E5-2690 v4 @ 2.60GHz (14 cores); CPUNumber=1},
@{Value=Intel(R) Xeon(R) CPU E5-2690 v4 @ 2.60GHz (14 cores); CPUNumber=2}}
Memory : 524288 MB
FLBAdapter : {@{EthernetFlexNICNIC0LOM11a=1-a 9C:DC:71:76:90:30; EthernetFlexNICNIC1LOM12a=2-a
9C:DC:71:76:90:38; FLBAdapterNumber=1}}
Mezzanine : {@{CardName=HP LPe1605 16Gb FC HBA for BladeSystem c-Class;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILO2xxxx; FirmwareVersion=2.74 May 08 2020;
IPAddress=1xxxx; MACAddress=70:10:6F:BC:6A:56;
PowerManagementControllerVersion=1.0.9; iLOFederationCapable=Yes}
Bay : 7

BladeStatus : No Server Blade Installed
Bay : 8

BladeStatus : No Server Blade Installed
Bay : 9

BladeStatus : No Server Blade Installed
Bay : 10

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c G6
PartNumber : 531221-001
SystemBoardSparePartNumber : 531221-001
SerialNumber : xxxx
UUID : 32313335-3132-5533-5631-313131394B4C
ServerName : Cxxx.com
AssetTag : [Unknown]
ROMVersion : I24 08/16/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=1},
@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=2}}
Memory : 196608 MB
Flex10EmbeddedEthernet : @{EthernetFlexNICLOM1a=1-a 18:A9:05:72:DD:08; EthernetFlexNICLOM1b=1-b
18:A9:05:72:DD:09; EthernetFlexNICLOM2a=2-a 18:A9:05:72:DD:0C;
EthernetFlexNICLOM2b=2-b 18:A9:05:72:DD:0D}
Mezzanine : {@{CardName=Emulex LPe1105-HP 4Gb FC HBA for HP c-Class BladeSystem;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO2; Name=ILO3xxxx; FirmwareVersion=2.29 Jul 16 2015;
IPAddress=xxx; MACAddress=18:A9:05:74:EE:2A;
PowerManagementControllerVersion=3.4; iLOFederationCapable=No}
Bay : 11

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c G6
PartNumber : 507784-B21
SystemBoardSparePartNumber : 531221-001
SerialNumber : xxxx
UUID : 37373035-3438-584D-5130-303230344C37
ServerName : xxxx.com
AssetTag : [Unknown]
ROMVersion : I24 08/16/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=1},
@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=2}}
Memory : 196608 MB
Flex10EmbeddedEthernet : @{EthernetFlexNICLOM1a=1-a F4:CE:46:BB:33:B0; EthernetFlexNICLOM1b=1-b
F4:CE:46:BB:33:B1; EthernetFlexNICLOM2a=2-a F4:CE:46:BB:33:B4;
EthernetFlexNICLOM2b=2-b F4:CE:46:BB:33:B5}
Mezzanine : {@{CardName=Emulex LPe1105-HP 4Gb FC HBA for HP c-Class BladeSystem;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO2; Name=ILOxxxx; FirmwareVersion=2.29 Jul 16 2015;
IPAddress=xx1; MACAddress=F4:CE:46:BC:28:28;
PowerManagementControllerVersion=3.4; iLOFederationCapable=No}
Bay : 12

BladeStatus : No Server Blade Installed
Bay : 13

BladeStatus : No Server Blade Installed
Bay : 14

BladeStatus : No Server Blade Installed
Bay : 15

BladeStatus : No Server Blade Installed
Bay : 16

 

 

even worse the g6 doesn't have the FLBAdapter it's using Flex10EmbeddedEthernet  , and neither display the card info

JohnM1
Occasional Advisor

Re: Get-HPEOAServerInfo not getting the FLB info

here is a different enclosure same result..

 

 

$serv.ServerBlade


Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c G6
PartNumber : 507778-B21
SystemBoardSparePartNumber : 531221-001
SerialNumber : xxx
UUID : 37373035-3837-584D-5130-313130413145
ServerName : xxx.com
AssetTag : [Unknown]
ROMVersion : I24 08/16/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=1}, @{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=2}}
Memory : 196608 MB
Flex10EmbeddedEthernet : @{EthernetFlexNICNIC1LOM1a=1-a D8:D3:85:B6:18:B0; EthernetFlexNICNIC2LOM2a=2-a D8:D3:85:B6:18:B4}
Mezzanine : {@{CardName=Emulex LPe1205-HP 8Gb FC HBA for HP BladeSystem c-Class; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO2; Name=ILOMxxx; FirmwareVersion=2.29 Jul 16 2015; IPAddress=xxx; MACAddress=D8:D3:85:63:1F:28; PowerManagementControllerVersion=3.4; iLOFederationCapable=No}
Bay : 1

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c G6
PartNumber : 507784-B21
SystemBoardSparePartNumber : 531221-001
SerialNumber : xxx
UUID : 37373035-3438-584D-5130-30323038364B
ServerName : xxx.com
AssetTag : [Unknown]
ROMVersion : I24 08/16/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=1}, @{Value=Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (4 cores); CPUNumber=2}}
Memory : 196608 MB
Flex10EmbeddedEthernet : @{EthernetFlexNICNIC1LOM1a=1-a F4:CE:46:BB:33:50; EthernetFlexNICNIC2LOM2a=2-a F4:CE:46:BB:33:54}
Mezzanine : {@{CardName=Emulex LPe1105-HP 4Gb FC HBA for HP c-Class BladeSystem; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO2; Name=ILOMxxxx; FirmwareVersion=2.29 Jul 16 2015; IPAddress=xxx; MACAddress=F4:CE:46:BC:28:0E; PowerManagementControllerVersion=3.4; iLOFederationCapable=No}
Bay : 2

BladeStatus : No Server Blade Installed
Bay : 3

BladeStatus : No Server Blade Installed
Bay : 4

BladeStatus : No Server Blade Installed
Bay : 5

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL460c Gen8
PartNumber : 666157-B21
SystemBoardSparePartNumber : 738239-001
SerialNumber : xxxx
UUID : 31363636-3735-584D-5133-353130383242
ServerName : localhost
AssetTag : [Unknown]
ROMVersion : I31 06/01/2015
CPU : {@{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz (8 cores); CPUNumber=1}, @{Value=Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz (8 cores); CPUNumber=2}}
Memory : 196608 MB
FLBAdapter : {@{EthernetFlexNICLOM11a=1-a 9C:B6:54:92:49:50; EthernetFlexNICLOM11b=1-b 9C:B6:54:92:49:51; EthernetFlexNICLOM12a=2-a 9C:B6:54:92:49:54; EthernetFlexNICLOM12b=2-b 9C:B6:54:92:49:55; FLBAdapterNumber=1}}
Mezzanine : {@{CardName=HP LPe1205A 8Gb FC HBA for BladeSystem c-Class; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILOxxx; FirmwareVersion=2.55 Aug 16 2017; IPAddress=1xxx; MACAddress=F0:92:1C:09:09:C6; PowerManagementControllerVersion=3.3.0; iLOFederationCapable=Yes}
Bay : 6

BladeStatus : No Server Blade Installed
Bay : 7

BladeStatus : No Server Blade Installed
Bay : 8

BladeStatus : No Server Blade Installed
Bay : 9

BladeStatus : No Server Blade Installed
Bay : 10

BladeStatus : No Server Blade Installed
Bay : 11

BladeStatus : No Server Blade Installed
Bay : 12

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL465c G6
PartNumber : 539800-B21
SystemBoardSparePartNumber : 509588-001
SerialNumber : xxx
UUID : 38393335-3030-5355-4530-31343033304A
ServerName : ESMTRUMGRRRD01
AssetTag : [Unknown]
ROMVersion : A13 05/02/2011
CPU : {@{Value=Six-Core AMD Opteron 2200 MHz; CPUNumber=1}, @{Value=Six-Core AMD Opteron 2200 MHz; CPUNumber=2}}
Memory : 65536 MB
EmbeddedEthernet : @{Port=System.Management.Automation.PSObject[]}
Mezzanine : {@{CardName=Emulex LPe1105-HP 4Gb FC HBA for HP c-Class BladeSystem; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}, @{CardName=NC325m Quad Port 1Gb NIC for c-Class BladeSystem;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=2}}
ManagementProcessorInformation : @{Type=iLO2; Name=xxx-ilo; FirmwareVersion=2.12 Jul 16 2012; IPAddress=xxxx; MACAddress=F4:CE:46:BC:9B:3C; PowerManagementControllerVersion=Not Available; iLOFederationCapable=No}
Bay : 13

Type : Server Blade
Manufacturer : HP
ProductName : ProLiant BL465c G6
PartNumber : 539800-B21
SystemBoardSparePartNumber : 509588-001
SerialNumber : xxxx
UUID : 38393335-3030-5355-4530-313430333154
ServerName : xxxx
AssetTag : [Unknown]
ROMVersion : A13 05/02/2011
CPU : {@{Value=Six-Core AMD Opteron 2200 MHz; CPUNumber=1}, @{Value=Six-Core AMD Opteron 2200 MHz; CPUNumber=2}}
Memory : 16384 MB
EmbeddedEthernet : @{Port=System.Management.Automation.PSObject[]}
Mezzanine : {@{CardName=Emulex LPe1105-HP 4Gb FC HBA for HP c-Class BladeSystem; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}, @{CardName=NC325m Quad Port 1Gb NIC for c-Class BladeSystem;
Port=System.Management.Automation.PSObject[]; MezzanineNumber=2}}
ManagementProcessorInformation : @{Type=iLO2; Name=xxxx-ilo; FirmwareVersion=2.12 Jul 16 2012; IPAddress=xxx; MACAddress=F4:CE:46:BD:41:EE; PowerManagementControllerVersion=3.4; iLOFederationCapable=No}
Bay : 14

BladeStatus : No Server Blade Installed
Bay : 15

BladeStatus : No Server Blade Installed
Bay : 16

 

Kashyap02
HPE Pro

Re: Get-HPEOAServerInfo not getting the FLB info

I tried on the Gen8 server. I got the same output as yours. I tried on the G7 Server. FLB information is not shown. 

Check the output of the Gen8 server. Notice that the name of the Mezzanine is listed. (

 

Type                           : Server Blade
Manufacturer                   : HP
ProductName                    : ProLiant BL460c Gen8
PartNumber                     : 666158-B21
SystemBoardSparePartNumber     : 654609-001
SerialNumber                   : CNXXXXXX
UUID                           : 31363636-3835-4E43-3732-323030325734
ServerName                     : BL460CG8002W4
AssetTag                       : [Unknown]
ROMVersion                     : I31 05/24/2019
CPU                            : {@{Value=Intel(R) Xeon(R) CPU E5-2660 0 @ 2.20GHz (8 cores); CPUNumber=1}, @{Value=Intel(R) Xeon(R) CPU E5-2660 0 @ 2.20GHz (8 cores); CPUNumber=2}}
Memory                         : 32768 MB
FLBAdapter                     : {@{EthernetFlexNICNIC1LOM11a=1-a 80:C1:6E:7A:92:B8; EthernetFlexNICNIC2LOM12a=2-a 80:C1:6E:7A:92:BC; FLBAdapterNumber=1}}
Mezzanine                      : {@{CardName=HP QMH2672 16Gb FC HBA for BladeSystem c-Class; Port=System.Management.Automation.PSObject[]; MezzanineNumber=1}}
ManagementProcessorInformation : @{Type=iLO4; Name=ILOBL460cG8002W4; FirmwareVersion=2.78 Apr 28 2021; IPAddress=10.65.140.189; MACAddress=E8:39:35:C3:55:94; PowerManagementControllerVersion=3.3.0; iLOFederationCapable=Yes}
Bay                            : 2

 

May be a limitation.. 

Try the same on Gen9 or above Generation server and verify the results. 

I am a HPE Employee

Accept or Kudo