BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

SOLVED
Go to solution
Ryan Schmotter
Occasional Visitor

HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

Hi all,
I have a HP (Nortel I assume) 10 Gb Blade C-class switch (full height). I am wondering if I set up a 802.1q tagged port, but do not make it a member of any VLAN's, will it pass all VLAN's, or does it implicitly drop all tags from Vlan's that it is not a member of. I.E: in Cisco land, if you make a port into a dot1q trunk, it allows all vlan's by default. Does the Nortel do the same thing, or do I have to add VLAN's as members?
Thanks!
5 REPLIES
Adrian Clint
Honored Contributor

Re: HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

Ryan,

I assume you mean double width not full height?
One of these from BNT?
http://h18004.www1.hp.com/products/blades/components/ethernet/10gb-bl-c/index.html

Looking the docs (application and command line).... I cant make it out... but I'm not a network guy.
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual〈=en&cc=us&docIndexId=64180&taskId=101&prodTypeId=3709945&prodSeriesId=3442811

Look for references to pvid & tagpvid


Or if you are still stuck....try asking the manufacturer support here
http://www.bladeconnect.com/modules.php?name=Forums
Ryan Schmotter
Occasional Visitor

Re: HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

Adrian,
That is the correct blade.
Thanks for the links, but I already checked the doco and it does not specify.
Lmm_1
Honored Contributor
Solution

Re: HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

It will drop all tags. On a BNT switch, the Port must be tagged on all VLANs that you need otherwise wont work, way different than Cisco but same as Procurve.

For example you need port x with untagged traffic on vlan 1 and tagged traffic on vlan 2,3,4.

Cisco
if# Switchport mode trunk
if# Switchport trunk allowed vlan 1,2,3,4

BNT
Port X# tag e
VLAN 2# add x
VLAN 3# add x
VLAN 4# add x

Procurve
VLAN2# tagged x
VLAN3# tagged x
VLAN4# tagged x

rgds,
Ryan Schmotter
Occasional Visitor

Re: HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

Thanks,
that is exactly what I was looking for.
Ryan Schmotter
Occasional Visitor

Re: HP C-Class 10 Gb Blade Switch (Nortel)-802.1q

OK,
I set up the dot1q trunks and added members, and still am unable to get the servers to talk thru the switches and the Cisco core (setup to allow default-all vlans)
Here is the scenario

- Servers are VM ESX 3.5. VMware is tagging using VST- where the V-switch is tagging, like in the document:
http://www.vmware.com/pdf/esx3_vlan_wp.pdf



- Here is the BL-C config (truncated)
/c/port 1
tag ena
/c/port 2
tag ena
/c/port 3
tag ena
/c/port 18
tag ena
/c/port 19
tag ena
/c/l2/vlan 2
ena
name "network"
def 1 2 3 18 19
/c/l2/vlan 3
ena
name "infrastructure"
def 1 2 3 18 19
/c/l2/vlan 4
ena
name "devtest"
def 1 2 3 18 19
/c/l2/vlan 5
ena
name "vpn"
def 1 2 3
/c/l2/vlan 6
ena
name "stage"
def 1 2 3 18 19
/c/l2/vlan 8
ena
name "iscsi"
def 1 2 3 18 19
/c/l2/vlan 10
ena
name "corecard"
def 1 2 3 18 19
/c/l2/vlan 20
ena
name "ecommerce"
def 1 2 3 18 19
/c/l2/vlan 30
ena
name "sql"
def 1 2 3 18 19
/c/l2/vlan 40
ena
name "blades1"
def 1 2 3 18 19
/c/l2/vlan 41
ena
name "vmbuild"
def 1 2 3 18 19
/c/l2/vlan 50
ena
name "blades2"
def 1 2 3 18 19
/c/l2/vlan 60
ena
name "blades3"
def 1 2 3 18 19
/c/l2/vlan 70
ena
name "blades4"
def 1 2 3 18 19
/c/l2/vlan 80
ena
name "AspectUIP"
def 1 2 3 18 19
/c/l2/vlan 192
ena
name "management"
def 1 2 3 18 19
/c/l2/stp 1/off
/c/l2/stp 1/clear
/c/l2/stp 1/add 1 2 3 4 5 6 8 10 20 30 40 41
/c/l2/stp 1/add 50 60 70 80 192
/c/l2/stp 1/port 1/on /fastfwd enabled
/c/l2/stp 1/port 2/on /fastfwd enabled
/c/l2/stp 1/port 3/on /fastfwd enabled
/c/l2/stp 1/port 18/off
/c/l2/stp 1/port 19/off
/c/l2/trunk 2
ena
add 18
add 19
/c/sys/syslog
host 10.20.3.24 -mgt
host2 10.20.2.30 -data
facil2 5
/c/ufd/on
/* /c/l3/if 250
* addr
* ena
/* /c/l3/gw 254
* ena
* addr

- Here is the Cisco Core switch config (truncated):

interface Port-channel100
description 20 Gbps trunk to Core2 t1/1 t1/9
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast disable


interface TenGigabitEthernet1/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast disable
spanning-tree link-type point-to-point
channel-group 100 mode on

interface TenGigabitEthernet1/9
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast disable
spanning-tree link-type point-to-point
channel-group 100 mode on


I verified the Etherchannel is up


No traffic seems to pass (dhcp requests, pings to static IP, etc)

Any ideas on what is wrong?