BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

HP FlexFabric 20Gb 2-port 650FLB Adapter support NPIV or NOT

binhvq
Occasional Visitor

HP FlexFabric 20Gb 2-port 650FLB Adapter support NPIV or NOT

Hi,

We have a chassis C7000 with 02 Virtual Connect 20/40 F8, blade server is 460c gen9 using flexlom 650FBL adapter. We already configured all thing work fine. However, now we want to assign virtual FC wwwp for some virtual machines to directly access LUN from SAN storage. We had first mapped for a virtual machine a RDM lun, then assigned virtual wwwp for it, next poweron it and esx server dump to purple screen and say something "tried to re-accquired lock vport_lock". We also tried to install hyperv intead of vmware on physical blade, then tried to create virual fibre channel but no luck, it say device or driver not support virtual fibre channel too.

So anyone can help me to confirm that we can do NPIV on 650FLB Adapter on balde 460c gen9? in this scenario it is like NPIV over NPIV because we used fc uplink ports from virtual connect to san switch for NPIV wwwp of physical blade server. Thanks in advance.

Regards,

BinhVQ

2 REPLIES
mikldk
Advisor

Re: HP FlexFabric 20Gb 2-port 650FLB Adapter support NPIV or NOT

Actually, we too have issues with 650FLB and NPIV in order to run Virtual Fibre Channel in VM's on Hyper-V 2012 R2.

We are able to create SAN Fabrics, however - our VM's make the destination host crash when trying to Live Migrate this VM.

I've created a support thread here as well : https://community.hpe.com/t5/ProLiant-Servers-Netservers/HP-FlexFab-20Gb-2port-650FLB-Adapter-Crashes-Hyper-V-Host-when/td-p/6915011

Kind Regards Mikkel Knudsen
mikldk
Advisor

Re: HP FlexFabric 20Gb 2-port 650FLB Adapter support NPIV or NOT

Hey Binhvq.

Our problem turned out to be a mismatch in firmware/driver metric from the behind laying IBM SVC's and and our 650FLB Firmware.

So what type of Storage SVC/Switches do you use?

Btw - please read here : https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2148123

Regarding the "tried to re-accquired lock vport_lock" issue.

Kind Regards Mikkel Knudsen