BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Help with VC Enet config

SOLVED
Go to solution

Help with VC Enet config

Hi all,i found this Cisco Switch configuration for 3 Vlans, 1 active VC module and 1 standby VC module, and i need some tips on how to configure my 2 VC 1/10Gb Enet modules, networks, uplinks, etc?

External Cisco Switch configuration:
interface Port-channel1
description "Port Channel to VC1"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
spanning-tree portfast trunk
!
interface Port-channel2
description "Port Channel to VC2"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
spanning-tree portfast trunk
!
interface GigabitEthernet0/1
description "VC1 Uplink 1, Po1"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/2
description "VC1 Uplink 2, Po1"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/3
description "VC2 Uplink 1, Po2"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
channel-protocol lacp
channel-group 2 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/4
description "VC2 Uplink 2, Po2"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3,4
switchport mode trunk
channel-protocol lacp
channel-group 2 mode active
spanning-tree portfast trunk

Any help plx.
Thx

JLR
10 REPLIES
Lmm_1
Honored Contributor
Solution

Re: Help with VC Enet config

You can do it on different ways, I´d recommend doing it this way if you are looking for an active-standby config:

- VC Ethernet Settings, Advanced Settings, Map VLAN Tags

- Create a Single Shared Uplink set using 2 Uplink ports on each VC Module

- Create three Vnetworks under the uplink set, one for each VLAN on the switch config

- Assign one or more of those networks to each NIC on the server profile as needed.


Is there an spefic reason to use the active-standby config? Check the cookbook on the link below, it has intructions for multiple scenarios:

http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c01471917/c01471917.pdf

Re: Help with VC Enet config

LMM thanks for the quick reply, I'll take a look to the manual and try this config.

points....u got it!!!
JLR

Re: Help with VC Enet config

I found in the manual that my requirement is the Scenario 2, and I need help about which is the configuration in the Cisco Switch for that configuration. I have 3 Vlans configured in the Cisco Switch 10,11 and 12. I think is something similar to what i have already config, but i want to be sure. Thx.

JLR
Lmm_1
Honored Contributor

Re: Help with VC Enet config

Scenario 2 is for 1 VLAN only? is that what you need? if so, under the Appendix A you will find the required switch config for each scenario

Re: Help with VC Enet config

Lmm thx, i just notice that hehehe, u r right, i need the Scenario 9, I have configured everything but my servers have Suse 9 installed and im looking for a software to configure Vlans on my servers, u know how to do this on Suse 9?

JLR
Lmm_1
Honored Contributor

Re: Help with VC Enet config

Re: Help with VC Enet config

Ok its getting very complicated, is there any Scenario to leave the connection without vlans?, i mean open connection to the cisco switch to have acces of any vlan on the switch, even if i have 2 vlans (10=192.168.1.x, 30=192.168.3.x) configured on my Cisco switch? Thx.
JLR
Lmm_1
Honored Contributor

Re: Help with VC Enet config

Yes, there are many different scenarios but it all depends of what you need. If your servers are on one VLAN only each, then you dont need to configure VLANs on the OS.

Re: Help with VC Enet config

Ok, here is the scenario:
2 sub nets: 192.168.1.x servers
192.168.3.x users
on the Cisco swicth are 2 vlans configured,
vlan10 servers
vlan30 users
I have 2 c7000 enclosures, one with standard lan switches (with conection, servers workin fine)and a new one with 2 VC 1/10 Gb Enet modules (no access, cant ping my servers), I need access to my servers from any of my 2 vlans. No need restriction on any vlan. Since I have Suse 9 on my servers, I dont want to create vlans on the servers,I want a simple config on the switches to get access.
Lmm thank u very much for your time.

JLR
Lmm_1
Honored Contributor

Re: Help with VC Enet config

In that case the switch must be configure to allows those vlans (Currently allowed 2,3,4), then use the config I suggested including VLAN 10 and/or 30 on the Uplink set Networks. After that create the Server profiles and assign one of those networks to the NICs. You can also contact support to get live assistance on this.