BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

How do I reset ilo settings back to defaults

ross stewart_2
Frequent Advisor

How do I reset ilo settings back to defaults

I have a blade, can't connect to ilo via oa. tried using ebipa to force an addres to it but nothing gets allocated. Server is in build stage so no prod ip address. How to I reset ilo to factory defaults via oa so I can start again?
6 REPLIES
Oleg Koroz
Honored Contributor

Re: How do I reset ilo settings back to defaults

easy way pull RTC battery out (CMOS battery)
ross stewart_2
Frequent Advisor

Re: How do I reset ilo settings back to defaults

ok but the blades are in a datcenter 75 miles from here and would prefer to do it remotely if possible.
James ~ Happy Dude
Honored Contributor

Re: How do I reset ilo settings back to defaults

Hello Ross,
You can address this from the host OS using the HPONCFG utility, "HP Lights-Out Online Configuration Utility for Windows 2000/Server 2003". (There is also support for Linux).

You can download the utility here:
http://h18013.www1.hp.com/support/files/lights-out/us/locate/69_5867.html

Also get the XML scripting examples, you will need them for reference.

You can download the docs, "Integrated Lights-Out 1.70/1.75 Scripting and Command Line Resource Guide" here:
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&locale=en_US&docIndexId=179166&taskId=101
TypeId=15351&prodSeriesId=397989

In the scripting examples, there is a script called "Mod_Network_Settings.xml" that shows how you can alter the network settings. You can configure the iLO to use either a DHCP-assigned IP address (and then attach using domain name), or a statically assigned address.

Regards.
Raghuarch
Honored Contributor

Re: How do I reset ilo settings back to defaults

Hi Stewart,

If you want to do it from OA,
you can run hponcfg from the OA CLI. have a xml script to set to Defaults.

Before setting iLO to factory defaults the make sure you have the password on the Toe-Tag.


CLI command.

hponcfg

Invalid Arguments

HPONCFG {NOAUTOLOGIN} [ALL | {[ , | - ] }] [ << marker> | {}]: Send a RIBCL script to the specified ProLiant
servers with the access level/privilege of the current user. Specify
NOAUTOLOGIN to use the login credentials in the script as is. The script may be
downloaded from a tftp, ftp, http or https URL. The results of which may
optionally be uploaded to a tftp or ftp location. To enter a RIBCL script
manually, type the "<<" marks and a string that does not appear within the RIBCL
script (so called end marker). Next, paste in the RIBCL script. Terminate the
command with the end marker.


Regards,
Raghuarch
ross stewart_2
Frequent Advisor

Re: How do I reset ilo settings back to defaults

again the problem is that they are effectively not available remotely ie they don't have a prod net ip as its not yet configured ie only way to get to them remotely is through ilo and via oa. I have used hponcfg but you need to be on the box to run it.
ross stewart_2
Frequent Advisor

Re: How do I reset ilo settings back to defaults

ignore my last post as I've just seen the reply re running hponcfg from cli on oa. One to try tomorrow.