cancel
Showing results for 
Search instead for 
Did you mean: 

ILO access.

SOLVED
Go to solution
bullz
Super Advisor

ILO access.

Hello Guruz,

I am very new to HP blade servers, I could able to access the ILO via webpage, but when I try to connect to sever, I am getting the below error.
Someone please help me.


HP CLI Commands:

POWER : Control server power.
UID : Control Unit-ID light.
NMI : Generate an NMI.
VM : Virtual media commands.
VSP : Invoke virtual serial port.


hpiLO-> VM
An iLO 2 License key is required to use Virtual Media.

• Note: Points will be given without fail.
6 REPLIES
Matti_Kurkela
Honored Contributor

Re: ILO access.

VM means Virtual Media: i.e. you could let the server use your workstation's CD-ROM, floppy drive or USB stick, or present an .iso image file on your workstation as a virtual CD-ROM drive to the blade. It has nothing to do with accessing the server's display.

As it says, the Virtual Media functionality requires an iLO 2 license key. If you have such a license key, access the iLO webpage, then go to Licensing and type in the key.

Is this a new blade with no OS installed yet? Which OS is this blade supposed to have? This command menu looks like the iLO of a Proliant blade, so it will never run HP-UX. An Integrity (Itanium) blade would present a somewhat different menu.

The VSP command might give you a command-line-based remote console... *if* the OS has been configured to present one to the iLO virtual serial port.

See pages 78-82 on the iLO User Guide to see what's possible with the VSP and how to configure your OS to allow it:
http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00209014/c00209014.pdf

MK
MK
bullz
Super Advisor

Re: ILO access.

Thanks for the voluble info.

To add more, Linux OS has been installed and up and running on two blades.
My problem here is, I unable to access the iLO via putty.

As soon as I am login I am getting the below prompt.
It would be great if someone explain me how to connect to the server via iLO through putty ( currently I am accessing server via webpage ).

HP CLI Commands:

POWER : Control server power.
UID : Control Unit-ID light.
NMI : Generate an NMI.
VM : Virtual media commands.
VSP : Invoke virtual serial port.


hpiLO-> VSP

Starting virtual serial port
Press 'ESC (' to return to the CLI Session

hpiLO-> Virtual Serial Port active: IO=0x03F8 INT=4


Itâ s getting hung when I try a â VSPâ
Matti_Kurkela
Honored Contributor
Solution

Re: ILO access.

In a blade server, the VSP virtual serial port is presented to Linux as /dev/ttyS0 serial port.

If you have not configured a "getty" process in /etc/inittab file for that serial port, there will be nothing listening for your VSP connection. At that point, the connection will seem to hang: the only thing that works is the "Esc (" keystroke to disconnect from VSP and return to the hpiLO prompt.

(Some firmware versions can detect that the serial port is not in use, and will display an error message and dump you back into hpiLO prompt.)

The procedure for configuring the Linux getty process for VSP use is listed in pages 81-82 of the iLO user guide I already mentioned:

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00209014/c00209014.pdf

Please, Read The Fine Manual.

(Note: like BL p-class systems, the newer c-class blades will have the serial port in the standard I/O address by default, so the setserial command listed in the procedure is not needed with blade servers.)

If that procedure has not been done yet, you can only use the "Remote console" access through the web page (which uses either ActiveX or Java to present the console window). This connection is not as user-friendly as PuTTY, but you might be able to use it to perform the VSP configuration procedure.

MK
MK
bullz
Super Advisor

Re: ILO access.

wow.. Cool, i got the console access after following steps.

But once i quit console and connect again, i am geting the below error saying " it's already in use"

hpiLO-> Requested service is unavailable, it is already in use by a different client.

Could you please help me here to reset the console?

Thanks in advance.
bullz
Super Advisor

Re: ILO access.

Also, i am geting an option for login while doing kill -HUP ageety process.

hpiLO-> VSP

Starting virtual serial port
Press 'ESC (' to return to the CLI Session

hpiLO-> Requested service is unavailable, it is already in use by a different client.

hpiLO->
gwl05524slb02 login: root
status=2
status_tag=COMMAND PROCESSING FAILED
error_tag=COMMAND NOT RECOGNIZED


but its giving some error once i guve user name.
bullz
Super Advisor

Re: ILO access.

Thanks to "Matti Kurkela" for the wonderful tip.

I am very happy and proud that i could able to connect to alom via putty too :)

Below i have mentioned the steps to reset the alom if connection is already exists..

1) Go to "Administration" tab
2) Select "Network Settings"
3) Click “Apply” to reset the iLO sessions.

Once again thanks to "Matti Kurkela".