BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

IP config on GbE2c after upgrade to 2.0.50

iulianv
Advisor

IP config on GbE2c after upgrade to 2.0.50

i upgraded one of the two GbE2c switches in a C7000 enclosure, from 2.0.0 to 2.0.50

after the upgrade the switch no longer took its IP address and gateway from EBIPA - connecting to it through serial cable revealed that the mgmt IP interface (256) wasn't there anymore; in order to enable it i have to assign a valid IP/mask to it (same applies for gatewway 4), and although both DHCP and BOOTP are enabled in the switch's system configuration, the information i enter for IP int 256 and gw 4 are persistent through reloads

how do i get the GbE2c to take its IP config info from EBIPA again?

thanks
13 REPLIES
Lmm_1
Honored Contributor

Re: IP config on GbE2c after upgrade to 2.0.50

Internal OA DHCP (EBIPA) will not override statically assigned IPs. Instead of assign the IP manually you should Run the EBIPA Wizard again... it might be due this fix included on v2.0.50

- Force DHCP request when script is copied to switch but contains no management interface information (affects switch when EBIPA used).

Rgds,
iulianv
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

well, i ran the EBIPA part of the First Time Setup wizard, with no luck

i also uploaded and applied a config script containing absolutely no interface information - again, no luck, it's like DHCP is disabled in this release :)

has anyone successfully upgraded a GbE2c from 2.0.0 to 2.0.50, and can still feed it IP management information through EBIPA?
Lmm_1
Honored Contributor

Re: IP config on GbE2c after upgrade to 2.0.50

Do you have an external DHCP connected to the OA, whats the OA Firmware version??
Lmm_1
Honored Contributor

Re: IP config on GbE2c after upgrade to 2.0.50

I ran into the same issue today, here is what I did.

When I made the update, if256 got disabled, if I assign an IP, EBIPA will not override it, if dont put an IP I cannot enable the if.

So, the key is, if you enable DHCP it will enable if256, then the OA DHCP (EBIPA) will asign the IP successfully.

Rgds,
lmm
iulianv
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

OA version 2.21, no external DHCP connected to the OA

enabling if 256 without assigning it an IP address doesn't seem to work - if i try that, it will complain about "Invalid address / mask pair for IP interface 256." (it seems to default to 0.0.0.0/0.0.0.0)
guru4hp
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

Well I have same problem when I have update to version 2.0.50 on c3000. Good shutdown of complete c3000 and power up have resolve problem. You may try to reboot only OA, and to go trought wizzard, but you need to reboot also GBE2c, and that is why it is good to shutdown all, and power up.
Also it is recommended to update ILO2 on server, ROM, and then OA to latest version 2.25.
BR. Mladen ...
iulianv
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

powering down the enclosures is a bit out of the question right now, as it's already in production...

however, i accidentally came across the "OA reset" workaround after upgrading the OAs to 2.25 - after the OA reset with the upgrade procedure, i noticed that DHCP by EBIPA started working again for the problematic GbE2c

after that i upgraded another GbE2c to 2.0.50, the issue occured again, and after resetting the active OA everything came back to normal

i have two more GbE2cs to upgrade to 2.0.50, so i'll be able to finally "validate" the workaround :)
Jonas Back_2
Super Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

I had the same problem. Had to manually via serial cable enable if256 and set it to a static IP in /cfg/l3/if/256 using the CLI.

/cfg/sys/cur shows that "Use of DHCP for management interface configuration currently enabled".

EBIPA for Interconnect switches are set to assign IP-address to the Interconnect switches.

/info/sys/log does not show it gets the IP via DHCP (EBIPA) which they usually do.

Did you solve this problem?
iulianv
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

local HP tech support guys confirmed to me that resetting the active OA is required after GbE2c software update, in order for the DHCP-by-EBIPA to work again for the switch
Jonas Back_2
Super Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

Thanks for that info. I have informed HP tech support and asked if there's any other workaround to get EBIPA to work again without resetting the OA config.

Will post result here.
iulianv
Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

you're not resetting the OA config (that is, you don't bring it to its factory default settings) - you're just rebooting the OA, it should be harmless unless you expect tons of events to happen in the enclosure during that minute that you absolutely need to be aware of :)
Jonas Back_2
Super Advisor

Re: IP config on GbE2c after upgrade to 2.0.50

Ah, I'll see. However, I think also removing the switch and putting it back also resolved the problem (note: not just powering off and off via the OA but physically removing and putting it back).

Re: IP config on GbE2c after upgrade to 2.0.50

Hello

I Can't tell if firmware 2.0.50 caused this situation for one of my customers. But for som reason the assigned a static IP via CLI.

I had some trouble reverting it to EBIPA assigned adress. After several reboots of both OA and Gbe2c switch, removing/reinserting switch etc. I firmware updated one switch to 2.0.60, this didn't solve my problem, but at least the eventlog now told me that EBIPA DHCP adress is recieved, but due to IP-conflict it can't be assigned to mgmt interface (256), also conflict on gateway to be assigned (4).
Via the WEB GUI i deleted both the L3 management IF (1) with static IP and deleted L3 Gateway (4)and hit the apply button. 30 milisecs later the switch was available at EBIPA assigned adress with link in OA GUI.

I guess the new 2.0.60 firmware isn't a part of the solution, but since it's so easy upgradeable I upgraded the 2. switch as well.

Hope this help you.