BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue Regarding Server Class Networking

John Turk
Occasional Contributor

Issue Regarding Server Class Networking

I don't know where else to send HP my feedback. There is no place to just get in touch with someone, so this seemed like the only place to do it.

First off, why don't you guys please just hire ONE person to design a decent UI for your GbE2c switches? Do they all have this ridiculous completely backwards-operating interface?

It's SO BAD that I spoke with at least THREE different HP techs on the phone who couldn't figure out how to use it. I even called in an HP on-site tech to come in under our 4 hour service contract. And we even had a consulting company take a look who has an HP and Cisco networking specialist.

So here's what's wrong with it, and I'm really sorry for the long rant, but I'm really upset that it took SO LONG to resolve with your tech support, and that I had to wait for a CALL BACK because there is no way to navigate your voice activated phone hell.

When you first open the interface for the GbE2c, you are presented with three BIG BUTTONS at the top; CONFIGURE, STATISTICS and DASHBOARD. The main frame shows the Switch Dashboard, and on the left frame, you see the "c-Class GBE2C Switch" which is BLUE and UNDERLINED.

So what do you guys really expect a user to do? Well first off it's a WEB interface, so when you see blue and underline you assume it's a link to click on. Been that way, since what? The late 80s? When was NSCA Mosiac designed? Also, when you have three buttons at the top you expect to see those do something.

I for one expected the configure button to do something like, oh I don't know, bring up a configuration menu for the switch. Instead, you click on it, and it does nothing. So you click statistics, assuming you will bring up some charts, graphs or numbers, but what does it do? Nothing!

So what did I do? I called HP tech support. The first time I called, I had to wait to get a call back, which I never got. Then I got someone on the phone WHO WAS AN HP TECHNICIAN who looked at it and couldn't figure out WT was wrong with this switch. He thought it might be bad, sent out a service tech who works on these ALL DAY LONG and couldn't figure out the web interface. He swapped out another unit that has the same stupid web interface...

After exhausting my day with the support technician, enabling and disabling things in the CLI, trying all different things to work, we decide to send it off to someone else to look at it.

So I get the call back today. The technician asks me if I "clicked the folder." And I said "Yeah, you mean the folder that says "c-Class GbE2c Switch?" and he says "YES." And then I tell him "Yes, I've clicked on the switch about a million times and nothing happens."

So then he asks to remote into the system, which I let him do, and I show him what's up. Then he goes "No, you have to actually click on the folder."

So it turns out, no you don't click on the text that is blue and highlighted which indicates a link, you don't click the big huge buttons at the top of your screen. The only way to access ANY FEATURE of the switch is to click the folder icon NEXT TO THE TEXT, which expands out a menu.

Now, I'm no user interface expert, but I know that when you have a folder that should expand, there should a a little plus next to it that looks like . That INDICATES that you can expand the folder.

Also, when you only have ONE folder, and a big long empty page, why on Earth didn't you set up that folder to be expanded by default. OR give SOME indication that you need to click the folder.

Do you realize that the ENTIRE switch configuration requires you to click on that stupid little folder icon? Totally ridiculous, HP. Totally ridiculous. Did you even test this interface out with a single person who wasn't on the interface design team and ask them how it is to work with?

Also while we're on the topic of web design. Do you understand what the point of a Web Interface is for? It's for easy access from ANYWHERE, from ANY MACHINE. Yet, you guys require Internet Explorer. Hello? How are you supposed to access it from a Mac or Linux system? Why do you have to use crazy, ridiculous ActiveX controls and Java interfaces just to configure a switch. It's really amazing what HTML and some simple forms and CGI can actually do. There's NOTHING in that interface that should require it. Basic, basic HTML so that ANYBODY can administer it anytime from anywhere. And so that it doesn't go out of date, so that 5 years from now (you do expect this to still be working then right?) I can pull up a new web browser and STILL access the interface without it being broken.

So anyways, I hope the point of this rant is pretty clear, that this interface is terrible, and that terrible web interfaces for your hardware need to STOP immediately. It's not to pick on your support technicians, who were great to work with. I hope this gets passed on to the right people, and that you guys decide to hire at least ONE user interface expert in your company to review your products. And I hope this doesn't get ignored and brushed off. It's a serious issue that really needs to be addressed if you want technically savvy people to look at your products and think that you put any thought into them at all...

2 REPLIES
Dennis Handly
Acclaimed Contributor

Re: I am so upset with HP right now...

This is the wrong forum for server class networking questions. For blades there is the ITRC forum for Servers > HP BladeSystem:
http://forums.itrc.hp.com/service/forums/categoryhome.do?categoryId=775

As to feedback to on GbE2c, you could try the feedback links on these URLs:
FAQ:
http://h18006.www1.hp.com/products/blades/components/ethernet/GbE2c/questionsanswers.html
Overview: (main page)
http://h18000.www1.hp.com/products/blades/components/ethernet/GbE2c/
WsComn
Occasional Visitor

Re: I am so upset with HP right now...

John.... I'm so sorry you had to go through this hell.  Like you, I was astounded by the strange behavior of the web interface of my HP switch.

 

I see a nice, pretty link:  Click ** ... nothing!  Click again ***...... again, nothing!  Repeat ad nausium!

 

If I had not found your post, complete with solution, I would have been on the phone to HP, too.

 

Thank you!  Thank you!  Thank you!

 

Click on the folder rather than the blue, underlined link (to nowhere).  Who would've thunk it?

 

Again, thanks!

 

Bill C.