BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Migrating from 1/10G VC to Flex10 VC - Anyone done it??

 
SOLVED
Go to solution
The Brit
Honored Contributor

Migrating from 1/10G VC to Flex10 VC - Anyone done it??

We are currently discussing the possibilities of upgrading our c7000 Production and development enclosures from 1/10G VC ENet modules to Flex10 modules.

We currently have VC ENet modules in Bays 1,2,3 & 4, and 4G FC VC modules in Bays 5,6,7 & 8. The enclosures contain a mix of bl860c's running OpenVMS, and bl465c G1/5 running Linux and Windows.

We want to replace the 1/10G VC Enet modules in bays 1 & 2 with Flex10 modules and I am trying to determine how much pain this will entail (in order to estimate maintenance window).

First basic question:

Can a Flex10 module import a VC Configuration file that was generated on a 1/10G module ? (he asked expecting the answer, NO!)

If anyone has done this themselves, I would appeciate any information/documentation/notes/scripts/observations/suggestions/... that you might be able to provide, either here in the forum, or directly to me via e-mail (address provided in my profile)

Thanks in advance

Dave.


6 REPLIES
Vincent Berger
Valued Contributor
Solution

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

The Virtual Connect Setup and Installation Guide (http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c01732252/c01732252.pdf) actually covers that case. Page 47/48

Vincent
The Brit
Honored Contributor

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

Hi Vincent,
Thanks for the pointer. I read it through and it "seems" to be fairly straight forward.

Hopefully this proves to be true

Dave
The Brit
Honored Contributor

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

There do seem to be issues when upgrading to Flex10 from the 1/10G VC ENet modules.

The upgrade procedure seems to work, and the config imports OK but servers do not have any network connectivity.

Profiles, VC Networks, uplinksets all show up as good, "Linked/Active". Viewed from the Network switch, everything looks fine. Log files contain nothing useful.

The problem seems to be between the Server NICs and the Flex10 Modules, but...

On top of all else, I have now heard a rumour that the Itanium Blades are not supported on Flex10 anyway. Which would be a real bummer.

Anyway, I'll let you know what I find out.

Dave.
The Brit
Honored Contributor

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

Final comments on this upgrade.

Dont do it! The procedure in the documentation (i.e. Virtual Connect for c-Class BladeSystem Setup and Installation Guide, Page 47/48) does not work.

We have spent ~8 weeks trying to make this work and to understand what the actual problem is, and it is this.

After doing the physical hardware swap, Step 7 says "Import the Domain". This works fine. Next action is to restore saved configuration file. This completely screws it up.

Before restoring the Config file, click on Enclosure bays and check the mappings for one of the flex10 modules. You should see that they are mapped d1 -> Bay 1, d2 -> Bay 2,... ...d15 -> Bay 15, d16 -> Bay 16.

Now restore the configuration.

you will now see that the mappings are reversed. i.e. d16 (is now at the top) and maps to Bay1, d15 -> Bay 2... ...d1 -> Bay 16 (at the bottom).

After many painful experiments and conference calls, we (and HP) concluded that the upgrade procedure (as given in the documentation) does not work.

If the VC domain is built from scratch on the new Fl;ex10 modules, the mappings stay correct, and it can be made to work. (I phrase it this way because there are many F/W, Driver and configuration hoops to jump though, depending on your servers and OS's.

I hope this saves someone some time and effort. As of present, there is no upgrade path from 1/10G VC to Flex10 VC which retains the original configuration. The build from scratch seems to be the only option, which requires an awful lot of prep work (although much of it can be scripted.)

Dave
The Brit
Honored Contributor

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

see final post
WFHC-WI
Honored Contributor

Re: Migrating from 1/10G VC to Flex10 VC - Anyone done it??

I wish I had seen this one before we tried the same thing. Our change was complicated by the fact that half of the enclosure was empty and we saw no problems until we added blades on the other side.

Where is the HP advisory on this?

Thanks for keeping us all posted with this one Dave!