BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

SOLVED
Go to solution
Martin Meadows
Occasional Contributor

Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

We need to determine the firmware version on the HBAs in our HP Proliant BL680C G5 Blades. They are running Linux version 2.4.21-58.ELvmnix. Any assistance is appreciated. Thank you!
7 REPLIES
Gerardo Arceri
Trusted Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

If i recall correctly the firmware is uploaded to the hba by the driver at the moment it gets loaded, but if you Hit Ctrl-Q to enter the Qlogic BIOS during Post you can see the "hard" firmware level.
Martin Meadows
Occasional Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

Thanks very much for your feedback.

I sure hope the only way to see the firmware version on the BL680C HBAs doesn't involve taking down the system.

Anyone else?

Thanks again :-).
Jan Soska
Honored Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

Yes, there are an easy ways.
a)
Log into SAN switch where is your server connected (locate the port first!),run Zone admin, find port of your server. go down the tree-list, at the bottom is your firmware and driver version.

b)
run HBA software to determine HBA firmware - Sansurfer if you have Qlogic, HbaAnywhere if you have Emulex ones. If not installed, install it first.

c)
could be determined via linux command, I am not sure about exact syntax, you need to use:
cat /proc/scsi/qla2300/* - just list /proc/scsi/....

Jan
Martin Meadows
Occasional Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

well ... we have brocade switches ... so it seems that we're not quite able to follow a couple of your suggestions ... although they all seemed very good ... and probably the HBAnware idea probably would work ... but ultimately in a roundabout way they helped us to the use of the linux lspci command which showed us:

12:00.0 Fibre Channel: Emulex Corporation LPe11000 4Gb PCIe Fibre Channel Host Adapter (rev 02)
12:00.1 Fibre Channel: Emulex Corporation LPe11000 4Gb PCIe Fibre Channel Host Adapter (rev 02)
16:00.0 Fibre Channel: Emulex Corporation LPe11000 4Gb PCIe Fibre Channel Host Adapter (rev 02)
16:00.1 Fibre Channel: Emulex Corporation LPe11000 4Gb PCIe Fibre Channel Host Adapter (rev 02)

... which seems to be enough information for our purposes although hbanwyware would probably give us a better number ...

Martin Meadows
Occasional Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

correction: the brocade switch thing only affects your first response.

With regard to your last response:
could be determined via linux command, I am not sure about exact syntax, you need to use:
cat /proc/scsi/qla2300/* - just list /proc/scsi/....

We found that the only file or data in /proc/scsi is a text file called scsi which has information about the symmetrix the Blade is hooked to ... but nothing about the HBA firmware.
Jan Soska
Honored Contributor
Solution

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

Hello Martin,

so - I can provide more detail...
At least we know you have an Emulex HBA foc c-class blades.

This will help you:
for 2.4 kernels, you can find the firmware version by typing cat /proc/scsi/lpfc/n, where n is the host adapter port that is represented as an SCSI host bus in Linux, for example, Firmware Version: 1.81 (H2D1.81X1)
After you ran it, you will know your firmware and you can use this HP link to download driver, firmware and HBAnyware utility to upgrade it if you want.
http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?lang=en&cc=us&prodNameId=1844101&taskId=135&prodTypeId=3709945&prodSeriesId=1844100〈=en&cc=us&submit=Go%20à »

to make it effective, you stil have to reboot the server.

I hope you are happy camper now... :)


Jan

Martin Meadows
Occasional Contributor

Re: Need HBA firmware info on BL680C running Linux 2.4.21-58.ELvmnix

Very happy. Thanks to all of you :-).