cancel
Showing results for 
Search instead for 
Did you mean: 

Operating System

SOLVED
Go to solution
Grayh
Trusted Contributor

Operating System

How will I knwo if an OS is already running on the Blade server...

When I boot the server it directly takes me to the Shell> prompt and stops there.


???????
15 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Operating System

Shalom,

uname -a

There may not be an OS installed or the boot configuration is trashed in some way if this is happening.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Duncan Edmonstone
Honored Contributor

Re: Operating System

The Shell> prompt is the NVRAM EFI prompt , which probably means there is no OS installed (it would probably have booted the OS if it was there).

If I recall correctly issue the following command to look for devices with EFI boot partitions:

map -r

If all you see are devices with blkN: identifiers, then those are all disks without EFI boot partitions.

If you see something with a fsN: identifier such as this:

Shell> map -r
Device mapping table
fs0 : Acpi(HWP0002,0)/Pci(1|0)/Usb(1, 0)/HD(Part1,SigC3072E18)

Then thats a bootable partition which probably has an OS on it (unless it's a bootable DVD in the DVD drive)

HTH

Duncan

HTH

Duncan
Jeeshan
Honored Contributor

Re: Operating System

seems that, your autoboot option is not set. check like as Duncan said.
a warrior never quits
Grayh
Trusted Contributor

Re: Operating System

On my blade server when logged in through the Mp I see the following errors and system Led's

UID: OFF
Server Helth: Off
Internal Healthy: Stedy Green

MP:SL (+,-,,D, F, L, J, H, K, T, A, U, ? for Help, Q or Ctrl-B to Quit) >



# Location|Alert| Encoded Field | Data Field | Keyword / Timestamp
-------------------------------------------------------------------------------
38 BMC 0 0 0x16801D4A00E00380 0000000000000000 INT_HEALTH_LED_STATE_CHANGED
09 Sep 2008 15:38:23
37 BMC 2 0x2048C6986F020370 040EA37004120300 CHASSIS_CONTROL_REQUEST
09 Sep 2008 15:38:23
36 BMC 2 0x2048C6986F020360 FFFF006F04140300 POWER_BUTTON_PRESSED
09 Sep 2008 15:38:23
35 BMC 2 0x2048C69867020350 FFFF006FFA220300 ACPI_ON
09 Sep 2008 15:38:15
34 BMC 2 0x2048C69866020340 FFFF027000120300 SOFT_RESET
09 Sep 2008 15:38:14
33 BMC 0 0 0x16801D4A00E00320 0000000000000001 INT_HEALTH_LED_STATE_CHANGED
09 Sep 2008 15:38:12
32 BMC 2 0x2048C69864020310 0401A37004120300 CHASSIS_CONTROL_REQUEST
09 Sep 2008 15:38:12
31 BMC 2 0x2048C69864020300 FFFF006F04140300 POWER_BUTTON_PRESSED
09 Sep 2008 15:38:12


MP:SL (+,-,,D, F, L, J, H, K, T, A, U, ? for Help, Q or Ctrl-B to Quit) >



# Location|Alert| Encoded Field | Data Field | Keyword / Timestamp
-------------------------------------------------------------------------------
30 BMC 0 0 0x16801D4A00E002E0 0000000000000013 INT_HEALTH_LED_STATE_CHANGED
09 Sep 2008 15:37:24
29 BMC 2 0x2048C698340202D0 6300A37063120300 CHASSIS_CONTROL_REQUEST
09 Sep 2008 15:37:24
28 BMC *7 0x2048C698330202C0 6300A87063120300 SHUTDOWN_OR_RESET_ON_SENSOR
09 Sep 2008 15:37:23
27 BMC *5 0x2048C698330202B0 FFFF030763020300 VOLTAGE_DEGRADES_TO_NON_RECOVERABLE
09 Sep 2008 15:37:23
26 BMC 2 0x2048C698330202A0 FFFF027000120300 SOFT_RESET
09 Sep 2008 15:37:23
25 BMC 0 0 0x16801D4A00E00280 0000000000000001 INT_HEALTH_LED_STATE_CHANGED
09 Sep 2008 15:37:22
24 BMC 2 0x2048C69832020270 0401A37004120300 CHASSIS_CONTROL_REQUEST
09 Sep 2008 15:37:22
Duncan Edmonstone
Honored Contributor

Re: Operating System

These aren't errors, they are chassis log messages.

I thought you said you were at the Shell> prompt?

To get back to the Shell> prompt press ctrl-b and then issue the command

co


Hope that helps...

Duncan

HTH

Duncan
Grayh
Trusted Contributor

Re: Operating System

Now I get the following

[1;33mShell> map -r
[0;37;40m [1;33mDevice mapping table [0;37;40m
[1mblk0 [0;37;40m : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBFE772,Lun0)
[1mblk1 [0;37;40m : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBCBF52,Lun0)

At the shell prompt when I type exit... It goes to the EFI and where I do not know what to do
Grayh
Trusted Contributor

Re: Operating System

I thought the below were errors:

8 BMC *7 0x2048C698330202C0 6300A87063120300 SHUTDOWN_OR_RESET_ON_SENSOR

09 Sep 2008 15:37:23
27 BMC *5 0x2048C698330202B0 FFFF030763020300 VOLTAGE_DEGRADES_TO_NON_RECOVERABLE

When the system is running normally what are the system LED and Health LED status
Grayh
Trusted Contributor

Re: Operating System

I get the following on One of the blades


Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBB2A52,Lun0)
blk1 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBEA862,Lun0)

and following on the other blades


Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBFE772,Lun0)
blk1 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBCBF52,Lun0)
Grayh
Trusted Contributor

Re: Operating System

I Also see the following:

I/O INFORMATION


BOOTABLE DEVICES

Order Media Type Path
----- ---------- ---------------------------------------




Seg Bus Dev Fnc Vendor Device Slot
# # # # ID ID # Path
--- --- --- --- ------ ------ --- -----------
00 00 01 00 0x103C 0x1303 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|0)
00 00 01 01 0x103C 0x1302 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|1)
00 00 01 02 0x103C 0x1048 XX Acpi(HWP0002,PNP0A03,0)/Pci(1|2)
00 00 02 00 0x1033 0x0035 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|0)
00 00 02 01 0x1033 0x0035 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|1)
00 00 02 02 0x1033 0x00E0 XX Acpi(HWP0002,PNP0A03,0)/Pci(2|2)
00 00 04 00 0x1002 0x515E XX Acpi(HWP0002,PNP0A03,0)/Pci(4|0)
00 01 01 00 0x14E4 0x16A8 XX Acpi(HWP0002,PNP0A03,100)/Pci(1|0)
00 01 01 01 0x14E4 0x16A8 XX Acpi(HWP0002,PNP0A03,100)/Pci(1|1)
00 02 01 00 0x1000 0x0054 XX Acpi(HWP0002,PNP0A03,200)/Pci(1|0)
00 02 02 00 0x14E4 0x16A8 XX Acpi(HWP0002,PNP0A03,200)/Pci(2|0)
00 02 02 01 0x14E4 0x16A8 XX Acpi(HWP0002,PNP0A03,200)/Pci(2|1)
00 03 00 00 0x103C 0x403B XX Acpi(HPQ0002,PNP0A08,300)/Pci(0|0)
00 04 00 00 0x1077 0x2432 01 Acpi(HPQ0002,PNP0A08,300)/Pci(0|0)/P
ci(0|0)
00 04 00 01 0x1077 0x2432 01 Acpi(HPQ0002,PNP0A08,300)/Pci(0|0)/P
ci(0|1)
00 05 00 00 0x103C 0x403B XX Acpi(HPQ0002,PNP0A08,400)/Pci(0|0)
00 07 00 00 0x103C 0x403B XX Acpi(HPQ0002,PNP0A08,700)/Pci(0|0)



Fast initialization: Enabled
MPS optimization: Disabled
System Wake-On-LAN: Enabled

BOOT INFORMATION

Monarch CPU:

Current Preferred
Monarch Monarch
CPU CPU
Module/ Module/
Logical Logical Warnings
------- --------- --------
0/0 0/0

AutoBoot: ON - Timeout is : 7 sec

Boottest:

BOOTTEST Settings Default Variable

Selftest Setting
--------- --------------
early_cpu Run this test
late_cpu Run this test
platform Run this test
chipset Run this test
io_hw Run this test
mem_init Run this test
mem_test Run this test

LAN Address Information:

LAN Address Path
----------------- ----------------------------------------
*Mac(001F29F28006) Acpi(HWP0002,PNP0A03,100)/Pci(1|0)/Mac(001F29F28006)
Mac(001F29F28007) Acpi(HWP0002,PNP0A03,100)/Pci(1|1)/Mac(001F29F28007)
Mac(001F29F28004) Acpi(HWP0002,PNP0A03,200)/Pci(2|0)/Mac(001F29F28004)
Mac(001F29F28005) Acpi(HWP0002,PNP0A03,200)/Pci(2|1)/Mac(001F29F28005)


FIRMWARE INFORMATION


*System Firmware A Revision: 4.05 [4820]
PAL_A: 7.31/1.08
PAL_B: 1.14
EFI Spec: 2.00
EFI Intel Drop: 14.62
EFI Build: 7.13
SAL Spec: 3.20
SAL_A: 2.00
SAL_B: 4.05
POSSE: 0.24
ACPI: 7.00
SMBIOS: 2.3.2a
System Firmware B Revision: 4.05 [4820]
BMC Revision: 5.32
IPMI: 1.00
Management Processor Revision: T.03.06
Updatable EFI Drivers:
Floating-Point Software Assistance Handler: 00000118
Broadcom Gigabit Ethernet Driver: 00090404
SCSI Bus Driver: 00000031
SCSI Disk Driver: 00000020
SCSI Tape Driver: 00000030
Usb Ohci Driver: 00000040
USB Bus Driver: 00000020
USB Bot Mass Storage Driver: 00000020
Generic USB Mass Storage Driver: 00000020
CLPrelay App: 00000100

* Indicates active system firmware image

WARNING AND STOP BOOT INFORMATION


CHIP REVISION INFORMATION

Chip Logical Device Chip
Type ID ID Revision
------------------- ------- ------ --------
Memory Controller 0 4032 0020
Root Bridge 0 4030 0020
Host Bridge 0000 122e 0032
Host Bridge 0001 122e 0032
Host Bridge 0002 122e 0032
Host Bridge 0003 4037 0022
Host Bridge 0004 4037 0022
Host Bridge 0007 4037 0022
Other Bridge 0 0 0030
Other Bridge 0 0 5007
Baseboard MC 0 0 0532


SYSTEM SECURITY CONFIGURATION
Trusted Boot: Not Supported
TPM: Not Present


Grayh
Trusted Contributor

Re: Operating System

Shell> map -r
Device mapping table
fs0 : Acpi(HWP0002,PNP0A03,0)/Pci(2|0)/Usb(1, 0)/CDROM(Entry0)
blk0 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBFE772,Lun0)
blk1 : Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Sas(Addr500000E01CBCBF52,Lun0)
blk2 : Acpi(HWP0002,PNP0A03,0)/Pci(2|0)/Usb(1, 0)
blk3 : Acpi(HWP0002,PNP0A03,0)/Pci(2|0)/Usb(1, 0)/CDROM(Entry0)
blk4 : Acpi(HWP0002,PNP0A03,0)/Pci(2|0)/Usb(1, 0)/CDROM(Entry1)

Shell> blk0
'blk0' not found
Exit status code: Invalid Parameter

Shell> fs0
'fs0' not found
Exit status code: Invalid Parameter

Shell> fs0:

fs0:\> hp-ux
'hp-ux' not found
Exit status code: Invalid Parameter

fs0:\>
Robert-Jan Goossens_1
Honored Contributor

Re: Operating System

Shell> fs0:

fs0:\> install

Robert-Jan
Grayh
Trusted Contributor

Re: Operating System

Hi Robert,

I have done that...

Looks like the OS is being Installed...
How can I install the OS at a strech in all the other blades after installing the OS in One of the Blades...

I have another 7 Blades for the OS to be Installed...

Could you give me a step by step procedure...

Also plz can u tell me how can I connect the other 4 baldes to this Enclosure ... I have some confusition with the MPDU...So that I can connect them and load the OS ...

Thanks in Advance
Grayh
Trusted Contributor

Re: Operating System

I am struck here.... what should I do now


* Preparing to execute init...
======= 09/09/08 10:27:01 EDT HP-UX Installation Initialization. (Tue Sep 09
10:27:01 EDT 2008)
@(#)Ignite-UX Revision C.7.5.142
@(#)ignite/launch (opt) Revision:
/branches/IUX_RA0803/ignite/src@72866 Last Modified: 2008-02-06
15:49:50 -0700 (Wed, 06 Feb 2008)
* Configuring RAM filesystems...
* Number of SAS devices swapped to be in physical
* Scanning system for IO devices...
* Boot device is: 0/0/2/2.0x2
WARNING: Could not find Q_BOOT device. Cannot determine what the boot device
was.
WARNING: Could not find source device in ioscan output. You must select from
the list of devices below to use for the source device:
index HW-path Class description
0) 120 processor Processor
1) 122 processor Processor
2) 124 processor Processor
3) 126 processor Processor
4) 0/0/2/0 OO USB_OHCI_Interface
5) 0/0/2/0.0x0 OO USB_Composite_Device
6) 0/0/2/0.0x0.0x0 OO Virtual_Keyboard
7) 0/0/2/1 OO USB_OHCI_Interface
8) 0/0/2/2 OO USB_EHCI_Interface
9) 0/0/2/2.0x2 OO USB_Composite_Device
10) 0/2/1/0 escsi_ctlr HP_PCI/PCI-X_SAS_MPT_Adapter
11) 0/2/1/0.0x500000e01cbfe772.0x0 disk HP_DG146BABCF
12) 0/2/1/0.0x500000e01cbcbf52.0x0 disk HP_DG146BABCF
13) 0/3/0/0/0/0 fc HP_4Gb_Dual_Port_PCIe_Fibre_Channel_Mezzani
ne_(FC_Port_1)
14) 0/3/0/0/0/1 fc HP_4Gb_Dual_Port_PCIe_Fibre_Channel_Mezzani
ne_(FC_Port_2)
15) 0/1/1/0 lan HP_PCI-X_1000Mbps_Dual-port_Built-in
16) 0/1/1/1 lan HP_PCI-X_1000Mbps_Dual-port_Built-in
17) 0/2/2/0 lan HP_PCI-X_1000Mbps_Dual-port_Built-in
18) 0/2/2/1 lan HP_PCI-X_1000Mbps_Dual-port_Built-in
19) 0/0/4/0 graphics PCI_Display_(1002515e)

Enter the index corresponding to the device to use
as the installation source, 'r' to rescan, or 'q' to reboot:
Grayh
Trusted Contributor

Re: Operating System

?????


anyguru online
Grayh
Trusted Contributor

Re: Operating System

thank you