BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

PXE timeout on hyper-v machines BL 460c G7

 
Andy Vanderbeken
Occasional Visitor

PXE timeout on hyper-v machines BL 460c G7

we just had a new BL 460c G7 with flex 10GBe converged network cards in. We fired it up into our C7000 enclosure, put latest firmwares on it, hyper-v core 2008R2 (and later sp1) with PSP 860 but we keep getting pxe timeout (errors 35 and 39) on this NIC. When we put in a 1GB mezzanine and start up our vm machines over the same vlan but over that netword card we dont' have any trouble at all so the card (even with latest firmware) seems the culprit. Would love it if anyone knew a fex to this !
19 REPLIES
AG Insurance
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Same problem here
Andy Vanderbeken
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

HP is troubleshooting this at lvl 2-3 support currently for me. During my own troubleshooting I found out that even at the bios lvl of the hp server you can enter the vlan, thus eliminating the OS (hyper-v 2008 R2) and therefore microsoft completely out of the picture. Even there the pxe boot hangs when doing it over that adapter, even with the 23february firmware relase for the 10GB emulex adapters (firmware 703) This confirms it totally being an issue with the adapters or at least it's firmware. In the meanwhile I'm using the other adapters until these are fixed
AG Insurance
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Ja dan maar wachten op een nieuwe driver of firmware.

Re: PXE timeout on hyper-v machines BL 460c G7

Hi all,
I've exactly the same problem.
Andy could you please tell me the HP case ID you've opened (just for reference).
Thank's a lot
Andy Vanderbeken
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

RE: case number: 4626212668 --> NC553i PXE issue

Thanks Andy for your time on the VR session and demonstrated us the issue more in-depth

Based on VR analysis, what we understand is,

- The NC553i NIC is in question not able to PXE boot the Citrix provisioning bootstrap image from the Citrix Provisioning server
- Checked the issue at the NIC BIOS level, assigned the VLAN but no luck
- The NIC gets an IP successfully from DHCP at BIOS as well as at Hyper-V guest OS during the PXE boot
- checked with the latest NIC firmware and the server BIOS, didnâ t help
- Disabled the VLAN support from NIC BIOS level, but no luck

Not sure if you have gone through the Citrix Best Practices for Configuring Provisioning Server on a Network - http://support.citrix.com/article/CTX117374, if not, I would suggest to go through it to see if any difference here.

Meanwhile, I am arranging the hardware (identical to your setup) in our one of global HP labs to see if I can duplicate the issue here and then take it further.

I will keep you updated about the further lab test progress.

Thanks
Patel, Hitendra (GCC ISS Engineer)


update: he's been busy in his lab for about a week now. I'm expecting news but by now we can't troubleshoot anymore. I had to take this server into production and put in an NC362 mezzanine since these 1GB broadcom interfaces don't have any problem.
Andy Vanderbeken
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

mail from the engineer just got in:

With regards to the PVS installation issue on BL460c G7 ServerEngine NICs, the issue is currently being investigated at HP Engineering jointly with Emulex.

Here is the latest update I have from HP Engineering:

Issue: Citrix PVS install issues on Server Engines NICs on BL460G7

Engineering Update:

â ¢ HP is expecting the SplitROM image update from Emulex at the end of the MAY time frame. However, HP to check with OEM until an image is provided.

â ¢ HP is now waiting for an update from the OEM to further move on this.

Will keep you posted about the further case progress on the case as and when I have any more news available from them.

Hitendra
HP ISS GCC
Simran Hansrai
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Has there been any update on this? I am running into a similar problem with my new BL460c G7 blades that are able to get a DHCP address but fail with a "PXE-E74: Bad or missing PXE menu and/or prompt information" error message. This is only happening on my G7 blades and the G6 blades are just fine.

Any update would be appreciated.

Thanks,
-Simran

Re: PXE timeout on hyper-v machines BL 460c G7

Hello all,

we are working hard together with HP. And it semms to go forward now. I hope next week I can say more about that issue.
Andy Vanderbeken
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

at your request I post here the latest reply from the assigned HP engineer received on 26-04-11:

"We are expecting an ALPHA code on 29th April form engineering to be checked in your test environment setup to confirm it works and share the result to our next level

Would it be possible to test the code in your test environment?"

Unfortunately by that time our 2 testservers had to be sent back so we could never test this firmware and we never will. This possible solution came too late for us and is of no use therefore. I hope however you can refer in your case to this and get a hold of the alpha firmware to test it. Maybe my invain patience and work on this may server someone else like yourself in the end. I myself however am through with this case and therefore will no longer be posting updates here. Cheers
Simran Hansrai
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Hi Andy,

Can you please provide me with this alpha firmware and I can test to see if this helps our issues?

Thanks,
-Simran
Marc Philips new
Occasional Visitor
Jase4772
Regular Advisor

Re: PXE timeout on hyper-v machines BL 460c G7

I'm having both the TFTP error on my BL460c G7 and HP RDP errors getting a DHCP address during the WinPE boot.

Glad to see its not my config but an issue with the NIC firmware. I'll be watching this thread!

Re: PXE timeout on hyper-v machines BL 460c G7

Hello,

We wait also with hurry for this NIC firmware since several weeks... but always no ETA :(

BR
GXD01
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Hi All,

 

Anyone ever find a solution to this or workaround? I am having the same issue, all latest firmwares installed.

 

Regards

Jim Miller
Frequent Advisor

Re: PXE timeout on hyper-v machines BL 460c G7

I just solved the issue of Hyper-V guests not being able to PXE boot on BL460C G7 with NC553i and VC FlexFabric modules in my test lab. We use HP RDP (Altiris Deployment Server) 

Hardware/Driver/Firmware versions:

Server BL460C G7 BIOS 2011.05.05

iLO3 Version 1.26

Chassis C7000 OA Version 3.31

VC FlexFabric Modules Version 3.15

OS version is Win 2008 R2 STD SP1

NIC Driver 2.104.277.3

NC553i firmware 2.104.281.0

Storage EVA8400 Cisco MDS 9513

RDP Installed from Insight Control 6.3 Media - Help-About shows Version 6.9 SP5

 

 I tried all of the following in this order:

1   Remove HP Net config utility. (We use NIC teams) Still fails 

2   Flash NC553i with Emulex branded firmware for OCe11102 version 4.0.360.3 Still fails

3   Install Emulex OCe11102 Ethernet Driver version 4.0.317.0 WORKS!!!!

4   Tried to re-install HP NCU 10.40 (cp014464) Works!!!! (NOTE: delete Hyper-V switch before creating teams)

 

I was very surprised that the HP NCU worked with the NICs running stock Emulex Drivers. The NCU has been one of the biggest thorns over the years. Always picky about NIC driver versions and such.

 

Yes, I realize this is not supported, but now I can move on to my next problem and wait for the updated driver from HP.

 

If the person that opened the case with HP could let them know that the issue is most likely in the NIC driver, perhaps this would get resolved sooner

 

Thanks

Jim

 

UPDATE: Althoiugh things looked good, Hyper V switch did not work when using HP NCU. Still works fince assigned direct to one NIC

 

 

 

 

 

GXD01
Occasional Visitor

Re: PXE timeout on hyper-v machines BL 460c G7

Hardware/Driver/Firmware versions:
Server BL460C G7 BIOSI27 05/05/2011
iLO3 Version 1.26
Chassis C7000 OA Version 3.32
VC FlexFabric Modules Version 3.30
OS version  Windows 2008 R2 STD SP1
NIC Driver 2.104.277.3
NC553i bootcode 3.104.281.0
Storage EVA4400
RDP 6.9 (Build 490) SP5

NCU 10.40.0.0

 

I also have a case logged with HP since yesterday, it's being escalated. I will let them know about your workaround and hopefully they can provide an updated driver. I need to keep our environment supported or I would give it a try - working around it just now with precreated sysprep'd type hard disks. Hope they can reolve this soon.

 

Jim Miller
Frequent Advisor

Re: PXE timeout on hyper-v machines BL 460c G7

ANy update from HP on a newer driver??

Jim Miller
Frequent Advisor

Drivers released

Just received the HP alert email. New drivers and NCU have been released. Downloading and testing now

 

 

 

 

Jim Miller
Frequent Advisor

Re: Drivers released

HP posted the WRONG flash image for the Emulex LOM. The file has the proper BE3 in the file name, but the file size is wrong, and OneCommand utility refuses to flash the adapter.

 

Every BE3 flash image file has been 16 MB, the one posted today is 8MB