HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems installing HPUX on Blade server

 
Francis Flan
Regular Advisor

Problems installing HPUX on Blade server

Having trouble in the EFI shell.
I have a BL860c and wish to install HPUX 11i.
It has 2x73GB internal disks and 12GB RAM.

At the EFI shell I have
blk0 : Acpi (HWP.......
blk1 : Acpi (HWP.......
blk2 : Acpi (HWP.......

The CD/DVD vMedia I connected is the "blk2" (i think).
Now do I mount this to a filesystem?: mount blk2 fs0
What happens next?

There's no CD/DVD drive in the enclosure so I'm using my own PC's through vMedia on the iLO.

Without the vMedia:
Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,PNPOA3,200)/Pci(1|0)/Sas(Addr5000C500053EF9A5,Lun0)
blk1 : Acpi(HWP0002,PNPOA3,200)/Pci(1|0)/Sas(Addr5000C500053E7C9D,Lun0)


With CD drive connected to vMedia:
Shell> map -r
Device mapping table
blk0 : Acpi(HWP0002,PNPOA3,200)/Pci(1|0)/Sas(Addr5000C500053EF9A5,Lun0)
blk1 : Acpi(HWP0002,PNPOA3,200)/Pci(1|0)/Sas(Addr5000C500053E7C9D,Lun0)
blk2 : Acpi(HWP0002,PNPOA3,0)/Pci(2|0)/Usb(0,2)

So im presuming that blk2 is the DVD. I'm expecting the DVD to be listed as a filesystem (like fs0)?
Any ides why this is or what I can do?

I tried "reconnect -r" and "map -r" but hasn't made a difference.
Anybody installed any OS on a BL860c before and encountered this?

please help!
Francis
9 REPLIES
Torsten.
Acclaimed Contributor

Re: Problems installing HPUX on Blade server

Still problems?

existing thread is

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1165553

What is your current status?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Francis Flan
Regular Advisor

Re: Problems installing HPUX on Blade server

Hi Torsten,
Still the same problem.

I'm trying to find out if there is another option to creating an image file - I haven't been able to test it yet.

From what i've read, I was expecting the CD in vMedia to appear as FS in the EFI.
Instead, whenever I connect a CD it appears as another block device (blk).

Is this a problem?
thanks
Torsten.
Acclaimed Contributor

Re: Problems installing HPUX on Blade server

I'm pretty sure you must create the image, because I think the vMedia can't provide the boot portion to the blade.
Also make sure your media is not too old (at least 06 or 09/2006).

Possible workaround is to use ignite from a different server or a USB connected DVD drive.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Sameer_Nirmal
Honored Contributor

Re: Problems installing HPUX on Blade server

Just wondering if you have enabled the iLO 2 Advanced pack features by entering the license key?

This is what I read from the iLO 2 Operations Guide available at

http://docs.hp.com/en/5991-5983/index.html

"On the BL860c server blade, an Advanced Pack license is bundled with the product. Although the license is bundled, the firmware does not automatically enable the Advanced Pack features. To enable the Advanced Pack features on the BL860c, you must enter the license key."

You can try Web GUI which I think would be more helpful.
Francis Flan
Regular Advisor

Re: Problems installing HPUX on Blade server

Hi Sameer,

Thanks for your reply.
The MP Advanced permanent license is enabled.

I'm reaching with this but:
Would vMedia recognize any CD in my local CD drive or is it set to only detect certain CD types compatible with Itanium systems?

I've ordered the Media Kit but have been trying to test the process with a software CD beside my desk. I haven't been able to detect it as a filesystem which is what worries me.

F
Sameer_Nirmal
Honored Contributor

Re: Problems installing HPUX on Blade server

As mentioned in the iLO 2 Operation guide ( link given in my last post ), EFI only supports DVD or CDs that contain data in the El Torito Bootable CD format.

I hope you have ordered HPUX OS/OE Media HP-UX 11.23 HWE 0606 or later which supports vMedia.

As another option is making a CD/DVD image file (El Torito bootable CD image) of the CD/DVD you have and boot off the system directly from the image ( or make CD using the image ). But then once OS is installed, it would require installing USB drivers for vMedia support.
rick jones
Honored Contributor

Re: Problems installing HPUX on Blade server

I would think there is a path through the EFI boot options screen to add a vMedia boot option to the list. I've never had to add one myself, it has always just been there. There should be no need to go the fsN: route.

It might be worthwhile to make sure that vMedia is "supported" for an HP-UX install rather than something which might simply "work" per the attached
there is no rest for the wicked yet the virtuous have no pillows
Francis Flan
Regular Advisor

Re: Problems installing HPUX on Blade server

I burned an image file to CD and it was finally detected by EFI.

thanks to all,
Francis
rick jones
Honored Contributor

Re: Problems installing HPUX on Blade server

In theory, you should have been able to point the java applet at the ISO you burned to CD and use that rather than having to burn to CD and vmount that. Still, if things are working, good.
there is no rest for the wicked yet the virtuous have no pillows