BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Server Exceeds MTU When NICs Teamed

mdelorie
Occasional Advisor

Server Exceeds MTU When NICs Teamed

I'm thinking I'm probably going to have to spend some time on the phone with HP support on this one, but I'll try here first.

Simply put, our blade servers are sending out frames exceeding 1514 bytes when the NICs are teamed. This is in spite of the configuration in both the NCU (Network Configuration Utility) and the NIC drivers themselves. When the NICs are not teamed, this does not occur. All applications on the server are affected.

This has been causing us serious grief as our switches are not currently configured to handle frames larger than 1514 bytes.

Any advice would be appreciated.
4 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Server Exceeds MTU When NICs Teamed

What kind of servers do you have?
Ali
HPE Pro

Re: Server Exceeds MTU When NICs Teamed

Hi Mdelorie,

this is because of Jumbo frame feature in NIC teaming which is being enabled in NCU properties.

Jumbo Packet. The size, in bytes, of the largest supported Jumbo Packet (an Ethernet frame that is greater than 1514 bytes) that the hardware can support.
o Default = Disabled
o Range = 4088 Bytes; 9014 Bytes; Disabled

If you switch does not support frame larger than 1514 bytes Disable this feature from teaming property.

Check the configuration guide for more options
http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00846707/c00846707.pdf

for more explanation, check this thread
http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/Jumbo-Frame-9014-mtu-radial-button/m-p/4072253#M69629



hope this helps,

thanks,
Aftab

I work for HPE
Looking for a quick resolution to a technical issue for your HPE products? HPE Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
mdelorie
Occasional Advisor

Re: Server Exceeds MTU When NICs Teamed

Aftab,

The jumbo frame feature is in fact not enabled and is set at the defaults. The NCU software is ignoring any settings I apply in that regard. Either that, or the LSO (Large Send Offload) is not working.

I spoke briefly with an agent at HP Support. He advised to investigate whether or not the issue continued to occur while using a different NIC teaming option (besides 802.3ad LACP.) I was unable to verify at that time, though I intend to. The agent advised that HP has been having problems with the NCU software for Server 2008. The servers are BL460c G6s

As a workaround, I have de-teamed my NICs and assigned one to our production VLAN, and one to the iSCSI VLAN. This has stopped the oversize frames from being generated for the time being. Of course, this is not ideal as we no longer have a redundant NIC set up.
Sely
Occasional Visitor

Re: Server Exceeds MTU When NICs Teamed

hi mdelorie,

It seems I've met same issues with my HP server ProLiant ML350 G6 (OS Windows 2003 server): MTU is set to 1480 bytes and Jumbo option is disabled on my teamed NIC card NC360T.

The whole system seems more stable when the NIC is not teamed. But, as you said, it is a workaround...

Please did you (or HP) manage to fix this issue ?

Thanks,
Marc