HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble with PXE

 
shlammed_1
Occasional Advisor

Trouble with PXE

Hello all, I have previously installed Red Hat on 12 blades in a c7000 chassis with no issue.

I was asked to deploy a newer version of Red Hat to 3 of them last week. I uploaded the ISO to my PXE server and installed fine on one of the three blades.

However, the other two blades will not work for the life of me. They both saw the DHCPD server and grabbed an IP at one point, but then couldn't mount the installation drive (no issue with the PXE server as I have tested using other blades).

After resetting the blades, I would try to PXE boot again and it would say something along the lines of the media being disconnected and to check cables, etc. which of course are all fine.

Does anyone have any idea what might be going on that is blocking them from even knowing that a DHCP server is on the subnet?

Since they are Cisco switches, I asked our networking guy to check the config on each port and they are all the same.
8 REPLIES
jdeavers919
Occasional Advisor

Re: Trouble with PXE

This might be a stupid question but did you enable PXE in the bios for the blades trying to PXE boot?

Also what interconnects are you using in the c7000 enclosure?

Thanks

John
shlammed_1
Occasional Advisor

Re: Trouble with PXE

Yes, PXE is enabled.

I have deployed all these blades using PXE when they were originally setup.

They also DID connect to the PXE server at one point but failed to do anything afterwards. Since then, I haven't even been able to get them to recognize the PXE server. They will not take a DHCP address and give an error saying that one is not available.

The interconnects are cisco catalyst switches.
shlammed_1
Occasional Advisor

Re: Trouble with PXE

ok, my problem just got weirder.

I went ahead and installed Red Hat on the blade by mounting the DVD remotely instead of trying PXE. the install went fine, but the blade could not get on the network VIA static or DHCP.

When I moved it to another chassis it picked up a DHCP address without any problems.

What the heck is going on? I have 10 other blades in this chassis that all work fine and even these two were working fine until I tried to re-deploy.
JKytsi
Honored Contributor

Re: Trouble with PXE

And what is the Cisco software version ? 10Gb NICs tend to want some later revisions.
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
shlammed_1
Occasional Advisor

Re: Trouble with PXE

I'll check, but if there are 10 other blades working fine, do you think it may still be the problem?

I don't want to have to take the other blades offline to fix this, but if i must...
shlammed_1
Occasional Advisor

Re: Trouble with PXE

So it turns out that the ports for the two blades went into error disabled.

Now the question is, what would cause that? Whenever I moved them to another slot in the same chassis it would disable the corresponding ports on the cisco interconnects.

If I moved them to a completely different chassis they would work fine.

Weird.
Dan Robinson_4
Regular Advisor

Re: Trouble with PXE

We use HP SA (aka Opsware) here and after TONS of similar issues like you reported, our Cisco guys figured out that PXE + Linux would fail miserably if "PortFast" wasnt set right.

Here is an excerpt from an email they sent me about the issue a while back, in regards to the config on the Cisco Port:

no cdp enable
spanning-tree portfast

In our case we use an Ethernet pass-through connected to a C6509E, but Catalyst is Catalyst so perhaps this will help.
Dan Robinson_4
Regular Advisor

Re: Trouble with PXE

BTW: PXE + Windows would work on the badly configured port, but occasionally would hiccup during the boot process and had to be kicked in the rear sometimes to force it to try again.