BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to enumerate rack components

Tony E Cook
Occasional Visitor

Unable to enumerate rack components

We have several P-class enclosures filled with BL20p G3 servers. When I try the option Rack View in iLO I will get the following error: "The server is not in a managed enclosure"

I see from another thread that the rack firmware upgrade has some prerequisites:
For Windows Operating Systems:
- HP ProLiant Rack Infrastructure Interface Service
- HP ProLiant Integrated Lights-Out Management Interface Driver
Check that these are current, as the enclosure manager needs all the links in the chain running to receive the firmware update.

I have installed the current management interface driver and verified that the rack infrastructure interface service is running. Running the rack upgrade utility still responds with "Unable to enumerate rack components" and rack view through iLO "The server is not in a managed enclosure".

People have suggested reinstalling firmware but how do you do this with the upgrade utility not working?

The PSP was installed from the SS CD v7.91 and I have tried booting from the FM CD v7.91 as well. The operating system on the server is Windows Server 2003 32bit.

Booting from the FM CD and selecting install p-class enclosure firmware produces these results:
Using pClass Enclosure firmware image : cpqrmm230.bin
***ILO exceeded the number of alloted backoffs, is it stuck ?
***ILO exceeded the number of alloted backoffs, is it stuck ?
Querying for pClass hardware configuration
Configuration error. Invalid pClass enclosure configuration
Press "Enter" to continue :

Pressing Enter returns me to the FM CD.

Any ideas or suggestions?
2 REPLIES
Oleg Koroz
Honored Contributor

Re: Unable to enumerate rack components

management module problems, run recovery per user guide and try physical reseat, swap from another enclosure if you have chance
asc_3
Frequent Advisor

Re: Unable to enumerate rack components

Hi Tony,

Please check the daisy chain of your enclosures.This error normally occurs when the daisy chain between the enclosures is not set properly.

The Rack Infrastructure should be then able to give you complete rack components.

Also,if this issue is seen only on one of the servers,if you can, please remove the server and re-insert it back.