BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Unusual Predictive Failure

SOLVED
Go to solution
Andrew Young_2
Honored Contributor

Unusual Predictive Failure

Hi All

I have just upgraded the firmware on all over BL460c services and the Onboard Administrators

One server now displays a predictive failure against the following category:

hpoa:devicePicFwVersion

This is the only server with this device showing.

Cna anyone tell me what this means. My suspicion is there is a problem with the power Management Firmware on the blade - which was not patched.

Firmware revisions are:

OA - 2.51
ROM I15 05/12/2009
ILO2 - 1.78 Jun 10 2009

Can anyone help telling me what the problem is?

Regards

Andrew Young


Si hoc legere scis, nimis eruditionis habes
10 REPLIES
The Brit
Honored Contributor

Re: Unusual Predictive Failure

I got a similar "predictive failure" message when I upgraded my OA to 2.51. I now have an inverted orange triangle against one of my blades (bl495c G5)

Checking the blade status (in OA) I see the following message.

"The power management controller firmware on this blade must be upgraded. Please see customer advisory c01668472."

It is now in the hands of the Proliant Admin.
TConn
Regular Advisor
Solution

Re: Unusual Predictive Failure

I got he same error also on the Blade in Bay 16. BL460c G1
I powered down the Blade, reseated it, pwoered it up and error didn't come back.
When the Blade had this error, I could not iLO into it. I could power it down and up, via iLO, but that was all.

Terry
Those who say it can not be done, should not interrupt those who are doing it.
Adrian Clint
Honored Contributor

Re: Unusual Predictive Failure

I would update the power firmware asap. Check the Firmware link in the OA interface. It will tell you if it is out of date.
You usually get a yellow/orange warning triangle if the BIOS and/or Powerfirmware need updating.
You need to match the firmware - the usual place
http://h18004.www1.hp.com/products/blades/components/c-class.html
And click on compatability
See...
V3.4(B)
Note: iLOv1.78 must be updated before updating V3.4(B) of the Power Management Controller
Andrew Young_2
Honored Contributor

Re: Unusual Predictive Failure

Hi.

We downloaded the CP010988.exe and CP010989.scexe patches:

Trying to install the firmware comes with the following response:

./CP010989.scexe
Flash Engine Version: Linux-1.2.0-0-8

Name: Online ROM Flash for Linux - Power Management Controller (c-Class blades)
New Version: 3.4

The software will not be installed on this system because the required
hardware is not present in the system or the software/firmware doesn't
apply to this system.

The Power Management Controller on this system does not support firmware updates.

We have been getting a similar response on a Windows blade.

The blade meets all the prerequisite patches according to the release notes.

However reseating the blade in question seems to have made the original error go away.
Si hoc legere scis, nimis eruditionis habes
kricotta
Occasional Visitor

Re: Unusual Predictive Failure

We are having the same issues when trying to update our BL460c blades to the 3.4(b) firwmare. I have installed ILO 1.78 as instructed and even rebooted the blade even though its not needed. When I run either patch cp010988.exe or cp010996.exe (note this is a 64bit OS) it fails with the "The Power Magement Controller on this system does not support firmware updates". We need this solved as we are having issues when these blades reboot and they are not recovering from a reboot. If you anyone has a solution please let me know.
kris rombauts
Honored Contributor

Re: Unusual Predictive Failure

If your PMC rev is 0.5 then there is no update needed , this is a good version that has all the needed features and functionailty for the build of the systemboard it is build onto. It cannot be upgraded.
The 3.4B is working on those blades/serves that have a PMC that can be upgraded and where it is indeed needed to do the upgrade.

A HP advisory should soon be released explaining this.

HTH

Kris



The Brit
Honored Contributor

Re: Unusual Predictive Failure

Notice also that the PMC V3.4(b) firmware pack is not supported on BL465 G1 blades (only G5 (or higher?))

Dave.
kricotta
Occasional Visitor

Re: Unusual Predictive Failure

The scope seems to indicate it is all 460C blades.

SCOPE

Any of the following HP ProLiant server models with an Integrated Lights-Out 2 (iLO 2) that has an embedded Power Management Controller with firmware version 0.7:

* HP ProLiant BL260c G5 server blade
* HP ProLiant BL460c server blade
* HP ProLiant BL460c G5 server blade
* HP ProLiant BL480c server blade
* HP ProLiant BL680c G5 server blade
* HP ProLiant BL465c G5 server blade
* HP ProLiant BL495c G5 server blade
* HP ProLiant BL685c G5 server blade
* HP ProLiant BL2x220c G5 server blade
* HP ProLiant xw2x220c Blade Workstation
* HP ProLiant xw460c Blade Workstation

Kirky_1
Occasional Advisor

Re: Unusual Predictive Failure

I'm having same issue but with xw460c workstations.
How do I check which version of PMC firmware I have?
Adrian Clint
Honored Contributor

Re: Unusual Predictive Failure

You can click on Enclosure Firmware on the top left pane of the OA. It will show you on the right pane.

Which OS is on your xw460s?