BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

FlexTenTen
Occasional Contributor

Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

Hello.

I encounter the following situation:
- 12x C7000 enclosure
- Interconnect Modules
- 2 X 1/10 VC-Enet Module in IM bays 1 and 2 ( FW 2.30)
2 C7000 enclosures with:
- 1 X 4GBb VC-FC Module in IM bays 3
I was requested to upgrade VC-Enet Modules to Flex-10 10Gb.

On all enclosures without 4GBb VC-FC Module everything was ok, no problems encountered. But with the two last here whats'a happen:

For the first one when I install the new Flex-10 10Gb with 4GBb VC-FC Module I do everything right, clearing, reseal, reseting all old informations about VC domains on OA and stared configuration like as the first time.

Unfortunately I get this error with the HP 4Gb VC-FC Module :
Interconnect Bay Status - Bay 3(HP 4Gb VC-FC Module) Overall Status: No Communication
Hardware Status: Unknown
VC Status: No Communication
OA Communication Status: Failed

I call the hotline and they dont try to search for a solution (I tried many things before call them) and they send me a new one. When I receive the new one I had a little error about an incompatibility firmware (by memory 1.X for the HP 4Gb VC-FC Module and 3.01 for the Flex-10 10Gb. I make an upgrade and everything comes right. So after this observation we said that with the hotline next time to try to upgrade fimware befor change the module with a new one.

So last friday I go to the datacenter and try it with the second enclosure who has also a HP 4Gb VC-FC Module. But, for a second time when I tried to upgrade the FW of the HP 4Gb VC-FC Module I had an error like this:

---------------------------------------------------------------------------------

C:\Program Files\Hewlett-Packard\Virtual Connect 1.4.1>vcutil.exe -a update -i 1
0.2.2.47 -u Administrator -p something -l c:\vcfwall301.bin -b 3 -vcu Administra
tor -vcp something

------------------------------------------------------------------------------
HP BladeSystem c-Class Virtual Connect Support Utility
Version 1.4.1 (Build 55)
Build Date: Jul 30 2009 16:27:09
Copyright (C) 2007-2009 Hewlett-Packard Development Company, L.P.
All Rights Reserved
------------------------------------------------------------------------------
The following modules will NOT be updated:
========================================================================
Enclosure Bay Module Current Version Status
========================================================================
GB88017LNS 3 HP 4Gb VC-FC Unknown Module inaccessible
Module
------------------------------------------------------------------------
There are no modules that need to be updated.
You can use the '-a report' option to display the details for the requested
update operation.
If you would like to try to force an update on the same or newer firmware
version, you can use the '-f version' option. If a previous installation was
not completed, please check the log file for more information.
---------------------------------------------------------------------------------
I try the -f option but same result. I try reseal, reset of everything (OA, VC...) I try a reset factory physically on each equipment... I think I try everything ... Somebody else encounter this kind of difficulties ? Just want to upgrade a VC can become a problem ? There is any bug or special best practice for this type of manipulation ?

Thanks for advice.
5 REPLIES
The Brit
Honored Contributor

Re: Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

Couple of suggestions.

1. On your OA. Check in EBIPA that the module still has an IP Address, and that the IP address is in the same subnet as the OA's.

2. If the IP is OK, I would pull the FC Module (during downtime), and reseat it, allowing it to reboot.

Dave.
FlexTenTen
Occasional Contributor

Re: Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

Thanks for your reply. When I show EBIPA, I see that the VC are ok, they have a corret IP but the SAN module has a 0.0.0.0 IP. Really don't understand :-(
FlexTenTen
Occasional Contributor

Re: Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

I try to attribute an IP fixe and the module never take it. He stays at 0.0.0.0
dchmax
Frequent Advisor

Re: Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

We attempted the 1/10 copper module to Flex10 Module and had no success, even following HP's documented steps. I ended up reverse engineering the configuration and built configuration scripts that I ran against the CLI to build the VC Domain from scratch.

Now I do understand your issue seems to be with the FC module, as TheBrit suggested I would attempt to reseat the module during a maintenance window. Confirm that the OA an VC domain reports the same information. When you did the VC upgrade did you follow HP's steps in restoring the VC config? Maybe this mucked things up. If you are able to build a VC domain from scratch successfully then there is a good chance the upgrade mucked things up.
FlexTenTen
Occasional Contributor

Re: Upgrade HP 1/10GB VC Enet to HP VC Flex-10 10Gb Enet

I find a part of solution and resolve a part of the problem.

At first, to answer at dchmax, my problem is not really the same. When I upgrade VC 1/10 to Flex 10 in most of my enclosure, everything was ok. I delete all informations of the old domain and create a new one. Everything was ok by this way.

But my problem was encountered just on the enclosures who has a SAN module. For the first one I try manythings and HP send me a new SAN module. When I put this new one in my enclosure (VC domain already configured) I just had an alert for incompatibilty firmware until VC Flex10 (2.12) and SAN module (I dont rememmber the FW but older than 1.32). I just upgrade my Flex10 with 3.01 FW and it upgrade automatically the SAN module to 1.40. A new information until yesterday is that I CANT CONNECT TO MY VC !!! When I pull off a server with a Server Profile configured and pull on after he says that he lost his Server Profile !!!

So, for the first problem, on my second enclosure who has SAN module today I find a solution. I receive a new SAN module in 1.32FW version. My VC Flex 10 was in 3.01FW version and I had a compatibity problem. I try to update the SAN module FW via vcutils: Failed. I try to downgrade my FW VC F10 to 2.33 and retest to upgrade SAN module to 1.40: Failed. Finally, I downgrade the VC F10 FW to 2.32 and everything become ok.

So, if we look at those experiences:
1. Look impossible to upgrade a 1/10 module to Flex10 module with a SAN module in the same enclosure (the SAN module never be recognize)
2. With a new SAN module, if you upgrade your VC F10 to 3.01 and SAN module to 1.40 it make your enclosure really unstable (denied access to the VC by http our ssh, lost of server profiles...)
3. With a new SAN module the more stable configuration is with VC F10 with a 2.32FW and SAN module with a 1.32FW.

My ticket is already open by HP and I'm going to identify this problem or bug... If you observe the revision history of F10 FW you can see that there were many bug fix for SAN module with the 2.30FW. I'll come bask here when HP give an answer.

Thank you for help !