BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

VC Flex-10 and Vsphere4: Smartlink not working

Peter Dressel
Occasional Advisor

VC Flex-10 and Vsphere4: Smartlink not working

There is the following phenomena:

In Interconnect Bay 1 and 2 are VC-Flex10 Modules.
Per VC there is one active Uplink
In VMware Vsphere4 the Blade has Vmnic0 connected to Uplink on VC1 and Vmnic1 is connected to Uplink on VC2.
Smartlink is checked. If one Uplink is down. The ESX server is not recognizing the lost link.
Versions: VC FW 2.32 and Vsphere4.
In Vsphere 4 the driverupdates are installed:

In an other enclosure with normal Virtual Connect Modules and ESX 3.5 it is working without problems.

Enclosed scheme and logs

Thanks in advance
Peter Dressel
4 REPLIES
Adrian Clint
Honored Contributor

Re: VC Flex-10 and Vsphere4: Smartlink not working

To get Smartlink working on Flex-10 and ESX4.0

You need to load the NIC firmware from the Firmware DVD 9.00. (or Broadcom NIC firmware 2.2.6 actually)

And you need a driver from Vmware that supports DCC.
http://downloads.vmware.com/d/details/esx_40_broadcom_bnx2xu1_dt/ZHcqYmRqcGhidGR3
DerekS_1
Frequent Advisor

Re: VC Flex-10 and Vsphere4: Smartlink not working

But VMware specifically states that the driver is not supported on Flex-10. It may work, but hasn't gone through any testing. So I'd be leary of using that in a production environment.
Peter Dressel
Occasional Advisor

Re: VC Flex-10 and Vsphere4: Smartlink not working

The latest versions of
"VMware ESX/ESXi 4.0 Driver CD for Broadcom NetXtreme II BCM5706, BCM5708, BCM5709, BCM5716 Ethernet controllers" was already installed (Version 2.9.7c from 2010-03-25

But Smartlink issue is still present.

Regards
Peter Dressel
HEM_2
Honored Contributor

Re: VC Flex-10 and Vsphere4: Smartlink not working

"VMware ESX/ESXi 4.0 Driver CD for Broadcom NetXtreme II BCM5706, BCM5708, BCM5709, BCM5716 Ethernet controllers" was already installed (Version 2.9.7c from 2010-03-25

That is not the correct driver for the NC532x NICs. You need the driver for Broadcom NetXtreme II BCM57710/BCM57711/BCM57711E

which Adrian correctly listed in his reply above:

http://downloads.vmware.com/d/details/esx_40_broadcom_bnx2xu1_dt/ZHcqYmRqcGhidGR3