BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

VC FlexFabric trunk to Cisco 4506 LACP active/active issue

Simon Haslam
Advisor

VC FlexFabric trunk to Cisco 4506 LACP active/active issue

Hello

I've got a c7000 with two FlexFabric modules and am trying to connect to a core network Cisco 4506 switch using two 1GbE fiber SFPs in each FF module (X5 and X6). The core network has several VLANs and I'm wanting to pass those through (tunnelled, i.e. no mapping) straight through to the blades. On the blades I'll use vSphere 4.1U1 to allocate different VLANs to different VMs.

According to the VC Ethernet Cookbook (Aug 2010, 3rd Ed) this looks like Scenario 1:3 ("Multiple Simple Networks
Providing Redundancy and Link Aggregation
802.3ad (LACP) with VLAN Tunneling"). As I have a single upstream switch it looks as though all ports should be active ("When all uplinks configured within a vNet connect a VC module to an upstream switch, ALL links could
be active, providing additional bandwidth, using Link Aggregation Protocol (LACP 802.3ad), this requires the upstream switch to be configured, on these ports, for link aggregation control protocol (LACP).")

The Cisco 4506 config is:

interface Port-channel3
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

interface GigabitEthernet2/6
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet2/8
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet2/10
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet2/12
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active

The switch shows this status:
#sh lacp internal
...
Channel group 3
LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State
Gi2/6 SA bndl 32768 0x3 0x3 0x9 0x3D
Gi2/8 SA bndl 32768 0x3 0x3 0xB 0x3D
Gi2/10 SA susp 32768 0x3 0x3 0xD 0x5
Gi2/12 SA susp 32768 0x3 0x3 0xF 0x5

(note the "susp" status on ports 10 & 12 which correspond to the connections to the FlexFabric module in bay 2)


My problem is that I get Linked/Active for Bay1:X5 & Bay1:X6 CORE1 but Linked/Standby for CORE2 Bay2:X5 and Bay2:X6. I was expecting all 4 ports to show as active (to give 4Gb total).

I've raised a call for this, but does anyone else have any suggestions?

TIA!


Simon
PS. the FlexFabric firmware is 3.18 2011-04-01T23:51:07Z & the C4506 is cat4500-entservicesk9-mz.122-31.SG
3 REPLIES
ColinF
Advisor

Re: VC FlexFabric trunk to Cisco 4506 LACP active/active issue

I believe that you issue is that you have configured an LACP group across VC modules. You should configure two groups, one for each VC module.
Simon Haslam
Advisor

Re: VC FlexFabric trunk to Cisco 4506 LACP active/active issue

Thanks for the idea Colin. At the moment we are investigating whether the problem is because the IOS version on the switch doesn't support LLDP - it's running 12.2(31)SG whereas it looks like LLDP was introduced in 12.2(44)SG (http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps4324/product_bulletin_c25_468227.html). For example, when we look at the vNet configuration it doesn't show the switch port MAC addresses on any of the links.

It's not clear from the Cookbook whether it is mandatory for the switch to support LLDP to enable Active/Active or not.
Casper42
Trusted Contributor

Re: VC FlexFabric trunk to Cisco 4506 LACP active/active issue

Based on your description, Colin's advice is the most logical.

If you create a Single Port Channel on the Cisco side or a Single Network/SUS on the VC side that spans 2 VC modules (Bay1 & 2 usually), you will find that only 1 module on the VC side goes active and the other stays passive.

This is done intentionally to prevent Spanning Tree loops and other such wonderfullness.

If you want Active/Active, you need to use 2 ChannelGroups on the Cisco side and then 2 different SUSs (and any Networks inside them) on the VC side.
SUS1A
- VLAN10A
- VLAN20A
-VLAN30A
SUS1B
- VLAN10B
- VLAN20B
- VLAN30B
etc


Another thing people often miss (you didnt) is to force the channel group into LACP mode. Cat switches with Port Channeling default to PAGP mode.
channel-protocol lacp
channel-group 3 mode active
^^ Those 2 lines are what is often missed.



PS, Idont see any VLANs listed as allowed on your config. Did you just strip them out?
switchport trunk allowed vlan 10,20,30 <-- example