HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

VC Module reboot after minor OA config change

 
zeroagemain
Frequent Advisor

VC Module reboot after minor OA config change

Hi There,
We noticed recently that the redundant OA in one of our c7000 chassis had lost it's IP address, but when we manually re-entered it from the active OA interface, it caused a reboot of all 4 (2 eth, 2 FC) Virtual Connect modules in the enclosure - causing a loss of ethernet connectivity, but more importantly a fairly catastrophic loss of SAN connectivity.

Has anyone seen this before, or have any info or advice? I appreciate we are not on the latest fware, but I'm pretty sure this shouldn't happen on any fware level, so I'm hoping for more than a 'upgrade fware' answer if possible. We have trouble getting downtime for fware upgrades owing to VC fware upgrades being so disruptive in the past (despite being advertised as non-disruptive in HP literature).

Thanks in advance and points will be awarded to any useful advice.

Fware levels below and logs attached;

Fware;
c7000 enclosure
Redundant OA's 2.51
1/10Gb VC Eth 2.00
4Gb VC FC 1.30


Thanks,
Brett
3 REPLIES
JKytsi
Honored Contributor

Re: VC Module reboot after minor OA config change

Sorry ...this problem is fixed by FW update (as several others too).

And updating VC was very troublesome, but current VCSU update will go pretty smoothly.
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
zeroagemain
Frequent Advisor

Re: VC Module reboot after minor OA config change

Thanks for the reply Jarkko.

Do you have a link or any info about the firmware upgrade that specifically deals with virtual connect issues resulting from resetting the IP of the passive OA?

Thanks,
Brett
JKytsi
Honored Contributor

Re: VC Module reboot after minor OA config change

Can't remember exact advisory (could have been OA fw advisory too).

But this looks like something for example

Version: 2.10 (14 May 2009)
Fixes
The following issues have been resolved in Virtual Connect v2.10:

Resolved a potential VC GUI hang if Internet browser is being used, and an uplink port cable is pulled from a VC Ethernet module.
Resolved a few unexpected pop-up error messages which might appear on VC GUI when the VC GUI browser was open on the Profile page and a server was powered on.
Resolved an issue that caused servers using FC to lose SAN connectivity when the primary Onboard Administrator (OA) module is reset.
Resolved a memory leak in VC Manager daemon that was triggered when both Onboard Administrator (OA) modules were absent.
Resolved issue that caused CLI to terminate the ssh sessions and logout the user when CTRL-C was entered in the middle of CLI command execution.

Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi