HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect Ethernet - Cisco Channel Config?

 
fishmn
Regular Advisor

Virtual Connect Ethernet - Cisco Channel Config?

Sorry for the long description but these things get complex!

We have put a lot of work into creating a std configuration for our c7000 enclosures including documentation. We connect our VCE modules with multiple GiGE uplinks channeled to seperate physical Cisco 6509 switches. We then setup seperate SUS's in VCM for both "legs". We then create an A and B Ethernet Network for the same VLAN from each SUS. We assign Ethernet A to NIC1 and B to NIC2 on our Windows2k3 blades then setup a TLB with preference order and round robin LB team for balanced transmit traffic.

This configuration works fine in function and throughput testing.. however it is going south when we do catastrophic network testing (shutting down distribution switches which should fail default gateway and subsequent traffic over to its redundant partner using HSRP). We find that a very similar physical and teaming configuration on our standalone DL servers will not fail. The key physical network differences are that we do not have channeled trunks to the DL like we do on the VCE modules. The following is running config on two of the channeled trunks. Could PORTFAST ON be an issue since the VCE is sort of a switch?


interface Port-channel13

description Testing c7000

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address



interface GigabitEthernet9/1

description C7000 Blades

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no snmp trap link-status

no cdp enable

spanning-tree portfast

channel-protocol lacp

channel-group 13 mode active

!

interface GigabitEthernet9/2

description C7000 Blades

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no snmp trap link-status

no cdp enable

spanning-tree portfast

channel-protocol lacp

channel-group 13 mode active

Thanks for any insight..

Ron

3 REPLIES
Adrian Clint
Honored Contributor

Re: Virtual Connect Ethernet - Cisco Channel Config?

Ron

Did you get this list of the commands from the Virtual Connect Cookbooks?

They are here if not and may help.
http://h41267.www4.hp.com/eventpage.aspx?&eventid=NgA4ADkA&cc=uk〈=en
fishmn
Regular Advisor

Re: Virtual Connect Ethernet - Cisco Channel Config?

I haven't looked at the cookbook in a while, I'll take another peek to see. Thanks for the advice.
fishmn
Regular Advisor

Re: Virtual Connect Ethernet - Cisco Channel Config?

The problem was solved by adding the "trunk" keyword to our portfast commands. This is part of the VCE cookbook configuration but I think our network people had always overlooked the keyword in the past.. by golly it is required for trunked ports!