BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Virtual connect Manager showing critical errors. Any advice...

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

Virtual connect Manager showing critical errors. Any advice...

Hi,

we have a c7000 with 4 x 1/10GB Ethernet VC modules and 2 x 4GB VC-FC modules. We have a shared uplink configured to use the first two ports on each module, with the link failing over whenever the live one dies. All this was working fine but now I am getting 2 critical errors in the VC Manager. Nothing has been changed, it's just started seemingly by itself.

The first error is beside Stacking Links, where it tells me that there are no stacking links in my setup. There are two linking cables linking the ethernet modules vertically. I have reseated these and the lights on the modules are on and flashing, but no change.

The second error is under the Hardware Overview in the "Unknown" tab. In here all the VC modules installed are listed, with the status of all the links showing "Not Linked 0Mb", whereas before it showed linked 1GB on the live link. Despite this the traffic is getting through and the blades are still on the network.

The update animation at the top of the screen is permanently on as well, with the error "Checkpoint Pending or Not Valid" as well.

Any simple explination or fix for any of this, if it can be done without bringing the whole chassis down then great....
17 REPLIES 17
Highlighted
Trusted Contributor

Re: Virtual connect Manager showing critical errors. Any advice...

Hi

Be worth posting your firmware levels of both OA and VC. Have seen similar issues on older versions of vc firmware.
Highlighted
Honored Contributor

Re: Virtual connect Manager showing critical errors. Any advice...

Hi Ewen,

I assume that you are seeing links on the X0 ports (i.e. the horizontal links between VC1 -> VC2, and VC3 - VC4.

I also assume that you are connected via X1, VC1 -> VC3 and VC2 -> VC4.

I would try power cycling the VC modules them selves, (allowing time for failover between each cycle.) I would probably do this with the virtical links disconnected and then reconnect them after all 4 vc modules have been cycled.
Also, you might try using X2 to link vertically (could be a bad port)

I have a similar setup, however I have not experienced this problem so I will be interested in your resolution.

Have you perhaps, upgraded FW recently?? I have experienced problems with this which required cycling to fix.

Note:: these are just suggestions, based on no actual experience of the specific problem.

Good Luck

Dave.
Highlighted
Occasional Advisor

Re: Virtual connect Manager showing critical errors. Any advice...

Hi,

OA is at F/W level: 2.21
VC is not reporting a firmware level, it's showing an unknown hardware state and minimal info. It was updated to the latest version when we installed the modules back in August though.

Thanks
Highlighted
Occasional Advisor

Re: Virtual connect Manager showing critical errors. Any advice...

Hi Dave,

I'm not seeing any links on any X port, even X0, the manages is showing everything as not linked. You are correct, I am connecting via X1, VC1 -> VC3 and VC2 -> VC4.

I will try power cycling the VC modules, and try using X2 to link vertically, not a bad idea.

No FW changes since the kit was installed in August.

Will let you know if I get a solution.

Thanks

Ewen
Highlighted
Trusted Contributor

Re: Virtual connect Manager showing critical errors. Any advice...

Agreed, power cycling the modules does seem to resolve this sort of thing. Though i would say it would be nice not to have to do this especially in production environments.

Any details in the system log file? Should alert if components have failed. Saying that, you say things are still ok at the blade end?
Highlighted
Occasional Advisor

Re: Virtual connect Manager showing critical errors. Any advice...

Everything is fine according to the OA. It's only when you log into the VC manager that you see any problems.
Highlighted
Trusted Contributor

Re: Virtual connect Manager showing critical errors. Any advice...

Can you get to the system logfile in VC?
Highlighted
Occasional Advisor

Re: Virtual connect Manager showing critical errors. Any advice...

Hi,

yes, I can get to the log. Attached it if anyone can make anything out of it then thanks.



Highlighted
Trusted Contributor
Solution

Re: Virtual connect Manager showing critical errors. Any advice...

Assume problem started on the 10th? Seen these type of errors in a previous post on this forum i think? Might want to do a search.

Looks to me like a bounce of the modules to get back functioning then check/upgrade the VC firmware. Check the release notes for the latest FW compatible with your OA version. There have been a number of reported issues and fixes related to this.