BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual connect fail update & fail failover

 
Primault
Occasional Visitor

Virtual connect fail update & fail failover

Hi there,


I’m experiencing many problems while upgrading or just trying a failover on Virtual Connects modules, with v1.34.

The configuration in the c7000 rack is :
- Blade ProLiant / Integrity firmwares updated to be up to date with OA 2.60 matrix
(except proLiant iLo, stayed at 1.78 in place of 1.81, due to iLo driver mismatch risks)
- OA 2.60 (upgraded from 2.32)
- VC-Enet 1.34 / Vc-FC 1.30

The goal is to upgrade VC-Enet to 2.12 & Vc-FC 1.32

Note : the customer use VCEM (v1.20)

The customer is preparing the enclosure to be updated as following :

1/ He launched the healthcheck from the vcsu 1.4.1 and it's ok (domain and module in sync)

2/ He tried to test the failover while clicking on “reset” virtual button of the VC in the OA interface.

There, the primary VC has been reset and the standby VC moved to active. A few ping packet loss on the servers after, the connexions had been restored.

But once he access to the VCM he found… the wizard… And the only operational credentials are the factory credential… just like the VCM has lost the config but nevertheless the servers are still available.

We tried to use the command " vcutil -a update -i -u -p -l -vcu -vcp -oe parallel " , but it didn't resolve the problem it moved to the VC 1 like active one and we have also the wizard.

As we have checked the enclosure and vc issue reported, the both VC modules are showing that either of modules are not in Active state.

And while we launch again a healtcheck through VCSU, domain and module in both vc are showed as “not in sync”.

It’s the second time we experience this case, the first time was while trying to update another vc (1.34 again) on an another c7000 rack (same firmware versions), and we needed to make upgrade offline, with server shutdown, vc shutdown

This time, we really need to find a way to restore the vcm access and update firmware without downtime, because the servers are really criticals…

I think there is something wrong with VCM.
- maybe they are waiting a checkpoint ?
- maybe there is an OA communication problem with VC(2.60 too high ?)


Any Ideas of the cause ? Any solution experienced ?

What do you think about the idea to physically remove and put again a VCM, waiting for restart, then same thing for the other ? Is it possible to do so online, without risk of configuration loss after the reboot ?

Thanks for any answer ! :)
4 REPLIES
Michal N.
Advisor

Re: Virtual connect fail update & fail failover

Hello,

I am not sure if I understand your problem fully, but as fair as I see it you want to update VC Enet FW from 1.34 to 2.12.
Version 2.x is not backwards compatible with 1.x, so there is not possiblility to restore previous settings, nor do that online.

The only way I know is to update VC version to 2.12 and reconfigure all the domain.

VC FC modules are not that critical here as only VC enet modules in bays 1,2 are running VC manager and those are the most important.

If you need some more explanation please let me know.

Regards,
Michal
Michal N.
Advisor

Re: Virtual connect fail update & fail failover

BTW OA 2.6 is not too high for VC's.
Primault
Occasional Visitor

Re: Virtual connect fail update & fail failover

Hi Michal,

Thanks for your answer.

Well, my goal is indeed to update these vc-enet fw 1.34 to 2.12 .

But before doing this, we :
- launched the healthcheck from the vcsu 1.4.1 and the situation was ok (domain and module in sync)
- in order to ensure all the servers are well redundant, then we tried a failover while using the virtual button â resetâ on the OA interface for the active VCM module


Then the standby VCM became active but like there was no configuration, we got the first time wizard and the only credentials which worked were the factory credentialsâ ¦

â ¦ but actually, no connexion loss for the serveur, so obviously the configuration is stell here.

And when we made another failover (using vcsu), the first vcm seemed to be again active, but with again the first time wizardâ ¦


So my problem is to restore online the vcm access before doing any upgrade,
without servers downtime, and understand what could be wrong.
Michal N.
Advisor

Re: Virtual connect fail update & fail failover

Hello,

From what you wrote it seems that Virtual Connect Manager does not know current configuration of VC modules, but luckly VC modules still hold this configuration.

From what I can tell VC manager is just application used to write changes on VC modules.

If you do not have backup of your configuration which you could restore.
Try to run:
vcutil -a configbackup -i -u -p [-vcu -vcp ]
Then try to restore configuration in VC Manager from this backup.

Otherwise:
I would schedule the downtime window and then try remove both VC Enet modules from enclosure and insert them back again.
Wait for 5 minutes and failover Active to Passive OA.

Kind regards,
Michal