BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

SOLVED
Go to solution
Brett Sadler
Advisor

aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

We have a C7000 enclosure populated with 8 blade servers. We want to aggregate bandwidth on the switches so we can just plug in a new cable from Cisco switch to HP switch and increase our bandwidth. I was told that FEC (Fast EtherChannel) is the way to go. Do we enable trunking on the HP side and enable EtherChannel on the Cisco side? When a network vendor enabled Trunking on both sets of switches, he caused a broadcast storm that took down our entire network in seconds. We are trying to avoid that issue also :). I don't have hardly any experience with practical switch configuration other than knowing the book work end of things. Any help would be appreciated! Thanks.
14 REPLIES
Lmm_1
Honored Contributor
Solution

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Hello,
The best option will be run LACP, it will create the channel automatically, and make it bigger when you add a new cable, if there is more than 1 VLAN traffic on the 3020 then you need to tag the ports also, it may look like this:

Cisco

interface GigabitEthernet0/22
switchport access vlan 100
channel-group 11 mode active

!
interface GigabitEthernet0/24
switchport access vlan 100
channel-group 11 mode active

Procurve

ProCurve(config)# int A1 lacp active

vlan 100
name "DEFAULT_VLAN"
untagged A1,A7-A10,A13-A24,B1-B24,Trk1
ip address 10.12.17.175 255.255.255.0
tagged A4-A6
no untagged A2-A3
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

What's the benefit of LACP versus static? I've heard from one of our network vendors that we would have nothing but trouble with it.

So, this weekend we enabled the following on both Cisco switches:
configure t
interface range gig 0/17 - 20
shutdown
switchport mode trunk (note we also tried switchport mode access per some info that we found on the web)
channel-group 5 mode on
not shutdown

Then on the HP 2824s we disabled the connected ports, changed the connected ports on each to Trunk5 and Trunk type (not LACP), and then re-enabled. POW! Broadcast storm. On the HP switches STP disabled the trunk/ports and on the Ciscos then I received an err-disabled for the port-channel 5.

Hopefully this will give more information to help with my problem. Thanks again so much!
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

What's the benefit of LACP versus static? It creates the pipe dinamically, with regular etherchannel you cannot just put a cable and increase bandwidht

switchport mode trunk (IEEE 802.1q, traffic from all VLANs will be allowed), if you use cisco as trunk, you need to tag the Procurve ports:

Cisco Trunk = Procurve Tagging = IEEE 802.1q

What type of STP are you running on the Procurve? Do you really want STP on the 3020? Please provide STP settings
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

I had seen that tagging was disabled on the Procurves when I used switchport mode trunk on the 3020s, but when I enabled tagging on the Procurve trunk, it still went down

I apologize if this isn't what you need, but I do not know a whole lot about STP. The protocol enabled on the 2824s is RSTP. The ports on the Procurves that I have connected to the 3020s are configured as edge ports and also as connected to point-to-point segments. I dont know if this matters, but the flow control is enabled on these ports.

On the 3020 switches, STP mode is PVST. As far as knowing whether or not I want to enable STP on the 3020s, I'm not entirely sure. Honestly, I just want our blade servers to be able to have plenty of bandwidth to the rest of our servers, which is all I'm looking for out of the 3020 switches.
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Use this document as reference, it will help you a lot

http://www.g33k.de/blog/wp-content/hp-cisco%20trunking.pdf

If you make 1 single channel from each cisco to each Procurve, and the crosslinks are disabled there is no need of STP
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Also should I enable spanning-tree portfast on the 3020 port-channel since the Procurve ports are configured as point-to-points. Thanks! I really appreciate your help!
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Thank you for that link. I am reading over the material as we speak.
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

PortFast should be enabled on the ports connecting to the blades only 1-16
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Per HP, their 2824s no longer allow the use of FEC in their latest OS/Rom releases, so it looks like LACP is the way to go. The document you gave me stated that LACP wasn't in use on any of the Cisco products. That's not true anymore so they should be able to auto-negotiate on both ends without manually configuring the trunks now?
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Cisco defualt mode should be desirable, not sure on the Procurve side, I would sugges Cisco as Channel-Group X mode active and lacp active on Procurve
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

What about STP? Should the LACP configuration not cause STP to disable the trunk ports?
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

If there is 1 single channel created between the switches there is no reason for STP to block the ports, and as I said before, if you only use, 1 channel for each cisco to each procurve and the croslinks are disabled (Cisco port 23 and 24), there are no redundant paths so there is no need of STP on the cisco switch.
Brett Sadler
Advisor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Last Question and then I have a plan to implement. You mentioned putting each cisco to each procurve on a Channel. Just for clarification purposes is it:

3020-1 > HP-1 = Channel 5
3020-2 > HP-2 = Channel 5

OR

3020-1 > HP-1 = Channel 5
3020-2 > HP-2 = Channel 6
Lmm_1
Honored Contributor

Re: aggregating bandwidth from 2 Cisco 3020's to 2 HP 2824 Procurves

Both will work, it could use the same name since are on different switches