BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

c7000 VC Ethernet module issues strange reverse lookup DNS requests

H_Bachner
Regular Advisor

c7000 VC Ethernet module issues strange reverse lookup DNS requests

I have a c7000 chassis with 2 VC Ethernet modules. All IP addresses are assigned by DHCP (which assigns de facto fixed addresses based on MAC).

Every 6 to 7 *seconds* I find the following DNS lookup requests in my local DNS server's log:

15:50:42: query[PTR] 49.46.48.49.in-addr.arpa from 10.100.1.43
15:50:42: forwarded 49.46.48.49.in-addr.arpa to
15:50:44: query[PTR] 49.46.48.49.in-addr.arpa from 10.100.1.43
15:50:44: forwarded 49.46.48.49.in-addr.arpa to

10.100.1.43 is the first VC module.

The ISP's DNS server does not resolve the reverse lookup request because
49.48.46.49 appears to belong to an IANA reserved address range.

Why does the VC module even ask for this address? I went through all configuration pages I can imagine but am unable to find a place where this address is mentioned/configured - neither in the VCE nor in the VC domain config.

These lookups create unnecessary load on both my and the ISP's name server and result in a DNS log file of 10 to 20 times the size before the c7000 was installed.

Any idea why these lookups are done and how to stop them?

Thanks & regards,
Hans.
5 REPLIES
Adrian Clint
Honored Contributor

Re: c7000 VC Ethernet module issues strange reverse lookup DNS requests

Check this IP is not somewhere else in the c-class OA config.

Best way is to download the OA config and log files and search them.
H_Bachner
Regular Advisor

Re: c7000 VC Ethernet module issues strange reverse lookup DNS requests

Adrian,

thanks for the suggestion. I downloaded the configuration and can't find any address except from my own LAN.

Any other ideas? Does noone else see the same phenomenon?

Thanks & regards,
Hans.
WFHC-WI
Honored Contributor

Re: c7000 VC Ethernet module issues strange reverse lookup DNS requests

Hans,

This does seem strange. Have any options been configured in your DHCP leases that may cause this?

Are DNS Server settings for your Active Onboard Administrator set properly?

If you use Enclosure Bay IP Addressing within the Active OA to give IPs to your interconnect modules rather than relying on your DHCP server, does the issue persist?

I may be grasping at straws, I admit I have not seen this before...
H_Bachner
Regular Advisor

Re: c7000 VC Ethernet module issues strange reverse lookup DNS requests

WFH-WI,

thanks for your suggestion. Due to some business assignments and vacation I won't be able to try it before September. I'll be back here once I know more.

Thanks & regards,
Hans.
H_Bachner
Regular Advisor

Re: c7000 VC Ethernet module issues strange reverse lookup DNS requests

After upgrading the firmware of the VC Ethernet modules to V2.31 the reverse lookup requests stopped.

A bit later I reset both VC Ethernet modules, the lookup requests were back. Then I reset the OA, the requests disappeared again.

As far as I can remember the sequence of events it appears that the requests always (mostly?) came from the standby module, whichever happened to have this role.

Hans.