BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

error encountered when installing Qlogic driver

philipho827
Occasional Advisor

error encountered when installing Qlogic driver

Hello folks,

I have a HP C-CLass bl 480c full height blade and in the process of installing the qlogic drivers that i downloaded from this site.

However during the installation i hit the following errors:
[root@pss1db3a hp_qla2x00-2007-10-05a]# ./INSTALL
Installing hp_qla2x00src RPM...

Preparing... ########################################### [100%]

Please install the kernel-devel package

error: %pre(hp_qla2x00src-8.01.07.25-1.noarch) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping hp_qla2x00src-8.01.07.25-1

Installing fibreutils...

Preparing... ########################################### [100%]
1:fibreutils ########################################### [100%]

I already have kernel-devel installed:
[root@pss1db3a hp_qla2x00-2007-10-05a]# rpm -qa |grep kernel-devel
kernel-devel-2.6.9-78.0.8.EL


Can someone please advice me on how to resolve this error? thanks
3 REPLIES
Jimmy Vance
HPE Pro

Re: error encountered when installing Qlogic driver

Is the kernel-devel package you have installed for the running kernel version?



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
philipho827
Occasional Advisor

Re: error encountered when installing Qlogic driver

Hi Jimmy,

i solved the problem already. need to update my kernel version to the latest.
I was using version 2.6.9-67.
Jimmy Vance
HPE Pro

Re: error encountered when installing Qlogic driver

Jimmy Vance
Is the kernel-devel package you have installed for the running kernel version?
-------------------------------------------
philipho827
Hi Jimmy,

i solved the problem already. need to update my kernel version to the latest.
I was using version 2.6.9-67.

---------------

That's basically what my answer was, you didn't mention what kernel was running, but generally if you have the devel package installed and get an error like what you have the running kernel and the devel utils don't match.

Don't forget to assign points





__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!