BladeSystem Management Software

Booting a Firmware DVD over a network with multiple NICs

 
mnewiger
Visitor

Booting a Firmware DVD over a network with multiple NICs

We boot HP Smart Update Firmware DVD using PXE on eth4.

FDT is started using a similar command in pxelinux.cfg:

 

label sos
MENU LABEL Automatic Firmware Update Version 9.00
kernel vmlinuz
append initrd=initrd.img media=cdrom rw root=/dev/ram0 ramdisk_size=257144 init=/bin/init loglevel=3 ide=nodma ide=noraid pnpbios=off vga=791 splash=silent showopts TYPE=AUTOMATIC iso1=nfs://192.168.0.99/path/to/fwdvd/image/FW900.iso iso1mnt=/mnt/bootdevice

 

We are not able to mount the ISO due to a network error. IFCONFIG shows that only eth0 is UP and configured using DHCP.

How can I change the default NIC to eth4 resp DHCP? Can these options be appended to vmlinuz?

 

Or is it possible to load the ISO in a second ramdisk and mount this?

 

Thanks.

2 REPLIES 2
chuckk281
Trusted Contributor

Re: Booting a Firmware DVD over a network with multiple NICs

Do you want to see if the latest DVD9.10(c) fixes the problem?

 

Just released :-)

 

Online HP BladeSystem c-Class Onboard Administrator Firmware Component for Windows - 3.11 (25 Aug 2010) http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=MTX-4130b90b217f4a6ba132aa4dfb&taskId=135&swLang=8&lang=en&cc=us&mode=3&

 

Smart Update Firmware - DVD 9.10 (C) (25 Aug 2010) http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=MTX-6eea1331b05640b68adaa764dd&taskId=135&swLang=8&lang=en&cc=us&mode=3&

 

If not, I will ask one of our guys to help.

mnewiger
Visitor

Re: Booting a Firmware DVD over a network with multiple NICs

Unfortunately the release 9.10C does not solve the problem.

 

Let me explain a bit more detailed.

We need to automate firmware deployment for our Blade Server Systems C7000/ BL460G6.

Each Blade has an embedded dual port NIC eth0 and eth1. Further we added a quad port Intel Mezzanine NIC eth2, eth3, eth4, eth5.

The appropriate VLAN is connected to eth4 and the blade is configued to PXE boot from eth4.

 

We boot the FDT and try to mount the FDT ISO for automatic deployment as described in chapter "Booting a Firmware DVD over a network" in the FW User Guide. The process fails.

 

IFCONFIG shows that eth0 is the only NIC with state "UP" and has an APIPA address since no dhcp is available for eth0.

I can bring eth4 up manually using:


    ifconfig eth0 down
    netconfig.sh --device eth4 --dhcp

 

Is there a way to automate this behavior?

Can we append something to the boot string or do I have to modify INITRD.IMG? In the latter case, which files has to be modified?

 

Any help is appreciated. Thanks.