BladeSystem Management Software

Cannot write to a virtual_drive mounted by iLO

 
chuckk281
Trusted Contributor

Cannot write to a virtual_drive mounted by iLO

iLO drive question from Joe and his customer:

 

***********

 

Greetings experts,

 

When mounting a local folder, via the iLOs Virtual Drives, CAN IT BE Writable?

 

Here’s from the customer:

On both iLO3 and iLO4

I log into the iLO

I start a Remote Console session to the Windows server.

I log into the Windows server (I have tried logging in with the local admin account and a domain account)

On the Remote Console Menu, I click on “Virtual Drives” and then click on “Folder”

Browse to a directory on my workstations C:\ Drive (I have also tried network shares) and select the directory)

I then see a new drive in Windows Explorer “Removable Disk (F:)

When I try to copy a file from the server to the local workstations C:\ Drive, I get the “Read-Only” error.  It doesn’t say anything about permissions.

 

The Documentation says

You can use the folder the same way that you use a locally attached device.

 

On a DL380 Gen8 with an iLO4, we use the Virtual Drives option to mount a folder from our local workstation.

 

When we try to Copy a file to the mounted folder, we get the following..

 

webpic329.png

  

Per the information from the “HO iLO 4 User Guide” I thought you could copy from  AND copy to a folder mounted as a Virtual Device, on a windows 2008 R2 Server.

 

Can you confirm if you can copy to a mounted folder.

 

 

Operating system considerations: Virtual Folder

• Boot process and DOS sessions—The Virtual Folder device appears as a standard BIOS floppy

drive (drive A). If a physically attached floppy drive exists, it is unavailable at this time. You

cannot use a physical local floppy drive and the Virtual Folder simultaneously.

• Windows—A Virtual Folder appears automatically after Windows recognizes the mounting

of the virtual USB device. You can use the folder the same way that you use a locally attached. Virtual Folders are nonbootable. Attempting to boot from the Virtual Folder might

prevent the server from starting.

 

********

 

Reply from Vincent:

 

*************

 

If you go a few pages further in that iLO4 user guide:

The Virtual Folder is nonbootable and read-only; the mounted folder is static. Changes to the client folder are not replicated in the mounted folder.

 

 ***********

 

Questions?