BladeSystem Management Software

Changing Enclosure Management IPs

 
chuckk281
Trusted Contributor

Changing Enclosure Management IPs

Russell had a customer question:

 

****************

 

Customer would like to change ALL management IP addresses in a c7000 enclosure.  OA, iLOs and interconnects.  Live, if possible.  It looks to me that the only issue with this is that when you make EBIPA changes in the GUI, hitting Apply will cause a reset on all interconnects at the same time and cause a network/SAN outage.

 

My suggestion was to make the changes via the OA CLI with the “set ebipa server” and “set ebipa interconnect” and then manually reset each iLO and each interconnect one at a time to avoid any interconnect outages.

 

Any advice or suggestions on this plan?

 

**************

 

Input from Dan:

 

**************

 

I’m 99.9% sure that Interconnects do NOT reboot when you change EBIPA.

EBIPA sets the DHCP Lease time to a very short time and so you should just be able to change the EBIPA values and then wait 5 minutes for it to roll over.

Its only Server iLOs that reboot when you make changes on the Device Bays screen.

 

I was at a customer site 2 weeks ago who had the wrong IP in EBIPA for a Flex-10 module and we changed it and the module did NOT reboot nor even present a warning message if I remember right.  Then because I was impatient and they had no servers running at the time, I force rebooted the VC module by hand to make it pickup the IP faster.

 

***************

 

Info from Mike:

 

****************

 

Current versions of OA ( I am not exactly sure when this changed)  will not restart the modules when making changes to the EBIPA configuration,  in fact from the GUI after choosing apply you will get a pop-up message that states the following –

 

“Note: interconnect modules in EBIPA-enabled bays will not receive an EBIPA address until their current DHCP or EBIPA supplied lease expires. This may take several minutes. Are you sure you wish to proceed?”

 

Or from the CLI in non script mode –

 

“It may take each interconnect several minutes to acquire the new settings.

 

Are you sure you want to change the IP address for the specified interconnect bays?”

 

As Dan indicated the lease time is very short, so you should pick up a new addresses within a couple minutes.

 

 

As for the iLO’s if you change an EBIPA address the iLO will be rest and it should pick up the new address, when making changes from the GUI you will get a message from the OA that states the following –

 

“Enabling or disabling EBIPA, or changing EBIPA settings will cause iLO Processors to be reset. Are you sure you wish to proceed?”

 

****************

 

Any other comments or suggestions?