BladeSystem Management Software

Firmware update with SUM

 
SOLVED
Go to solution
ljinde
Occasional Contributor

Firmware update with SUM

Hello All,

I am trying to update firmware with SUM tool. I have installed SUM tool and trying to below command.

<servername>:/mnt/iso/packages # ./smartupdate add --nodes x.x.x.x type=linux
Copying sum files to /var/tmp/localsum

Add in progress.Please provide user for x.x.x.x: ljinde
Please provide password for node x.x.x.x(ljinde):
....
Failed to add x.x.x.x: Incorrect username/password.
juet-owtest:/mnt/iso/packages #

I am giving the same password which I use for loggin into this server. The same password is used for loggin as root.

Any one have any idea if there are other credentials that I need to use ?

4 REPLIES 4
ShruthiSK
HPE Pro

Re: Firmware update with SUM

Hi, 

I believe you are incorrectly updating the username information. 

As per the SUM user guide, it states that if the node is a Linux node and part of a Windows domain, use the format : <domain>\<username>

Pg 79 : https://support.hpe.com/hpsc/doc/public/display?docId=a00018258en_us

Regards,

Shruthi (HPE Employee)

----------------

Was this helpful? Like this post by selecting the Kudos option below!

I am an HPE employee
Accept or Kudo
UKEngineer
New Member

Re: Firmware update with SUM

I am having a similar problem. I have changed the password for the user with sudo access, still get the same. Created a new user with sudo access, same error.  I ran it as root and got the same error.  I am unable to add my node.

I ran it with the username in the command and also like below, with all users i've tested with.

[root@node1 packages]# ./smartupdate add --nodes node1 type=linux
Copying sum files to /var/tmp/localsum

Add in progress.Please provide user for node1: root
Please provide password for node node1 (root):
....
Failed to add xpsnwy0042: Incorrect username/password.

---------------------------------------------------------------------------------

Per your comment above: These boxes are not on a Windows domain. The user guide is not helpful for this failure.  Is there something else to try or a workaround that will get this update running to get my server Firmware updated?

UKEngineer
New Member
Solution

Re: Firmware update with SUM

Work around for you:

if the server you are doing the update on is the one you are running the commands on, use localhost.

./smartupdate add --nodes localhost

this seems to bypass the user/password issue I was having.  I will update if I have any issues. But I finally got the node added... and the inventory is currently running.   Just don't add username=user password=password1 on the end of the command. Just run it outright.

./smartupdate inventory --nodes localhost --baselines /dir/2018.09.0/packages  

 

 

ljinde
Occasional Contributor

Re: Firmware update with SUM

Thank you @UKEngineer . The solution worked. I am able to add the nodes and inventory and deploy. But when I tyr I get below output. I am not sure if this because ythe server is up to date or am I missing something.

uet-owtest:/mnt/iso/packages # ./smartupdate add --nodes x.x.x.x
Copying sum files to /var/tmp/localsum

Add in progress.Please provide user for x.x.x.x: root
Please provide password for node x.x.x.x (root):
.................
Added x.x.x.x. Ready to start inventory.
uet-owtest:/mnt/iso/packages # ./smartupdate inventory --nodes x.x.x.x --baselines /mnt/iso/packages
Copying sum files to /var/tmp/localsum
Inventory in progress.....................
Successful inventory on node x.x.x.x. Node already at baseline version.
Successful inventory on baseline /mnt/iso/packages
Version: 2018.11.0
Name: Service Pack for ProLiant
uet-owtest:/mnt/iso/packages # ./smartupdate deploy --nodes x.x.x.x
Copying sum files to /var/tmp/localsum
Deploy in progress.......
1. x.x.x.x
Status: No applicable component found.

uet-owtest:~ # dmidecode | grep -i product
Product Name: ProLiant DL360p Gen8
String 2: Product ID: 654081-B21
uet-owtest:~ # dmidecode | grep -i firmware
Firmware Revision: 2.61
Status: Firmware-detected hardware failure
Power Management Controller Firmware
Power Management Controller Firmware Bootloader
Server Platform Services (SPS) Firmware
uet-owtest:~ #

 

I am updating with P11740_001_spp-2018.11.0-SPP2018110.2018_1114.38.iso