BladeSystem Management Software

HP SUM 6.2 and custom baseline problem

Go to solution
Valued Contributor

HP SUM 6.2 and custom baseline problem

Hi everyone,


I'm in the process of trying to build a package of HP SUM 6.2 with a custom baseline (because the size of the whole SPP is way too big and with custom baseline i can reduce the size to ~250MB) so I can deploy it to approx. 1000 Windows Servers.

First I tried to build the custom baseline through the HP SUM Web GUI. But there you aren't able to add Windows drivers only Firmware and BIOS.


I then added the driver components manually in the baseline directory and added the specific lines (each cpxxxx.exe) to the baseline xml file:

<package install="yes">cp019088.exe</package>
<package install="yes">cp021118.exe</package>
<package install="yes">cp022443.exe</package>

 So I tried to run it with the parameters (hpsum.bat /use_latest /allow_non_bundle_components /use_location "C:\Temp\hpsum\baseline" /silent) and waited about 1 hour but nothing really happened.

The components weren't updated and when I run the HP SUM through the web interface with the same manually edited baseline you can see the whole list with all drivers and firmwares not being up to date...


The hpsum_execution_log... file contains following:

START|'HP SUM 6.2.0."56".23426.x64'|Windows Server 8|'02-25-2014 10:36:24 am'
02252014-103624|02252014-103624|0|'IP:'|0|0|Server: HLAB70-S12<br>Current Directory: C:/Temp/hpsum.


When I try to update the same baseline through the Web GUI it works (except that it sometimes doesnt close the GUI after finishing and it looks like it is running endless...) so the components are getting updated.


Does anyone experience same issues with silent installation and custom baselines?


OS affected is Windows Server 2012 so far (will test also 2008 R2 later today)


Thanks and Regards,



Valued Contributor

Re: HP SUM 6.2 and custom baseline problem

well sorry for that post, I've found out that the issue was a wrong path in the "/use_location" parameter :-S

So it's working fine now ;-)