BladeSystem Management Software

HP Server deployment issue with PXE boot

 
chuckk281
Trusted Contributor

HP Server deployment issue with PXE boot

Johan was looking to help a customer with PXE boot problems:

 

***************

 

I visited a customer this week and installed Server deployment 7.1.1 (Altiris-RDP).

The CMS is a stand-alone RDP-server with Win2008R2 and lots of RAM etc. This is a pure Linux-environment and they run SLES11.

 

The problem is that the PXE-client never finds the PXE-server properly.

 

The customer DHCP-server, called Infoblox, is linux-based. Googling a lot since the RDP/Altiris Installation and Reference guides were no good gave the fact that we should enable a few DHCP options in the DHCP-server, as described in the link below.

 

Symantec KB-article: http://www.symantec.com/connect/articles/pxe-force-mode-linux-isc-dhcp-server

 

We enabled all the options stated in the KB-article, DHCP options:

43, 60, 66, 67 and 150

 

dhcp server set optionvalue 43 BINARY 06010B0807AAAA01868ACD1200

dhcp server set optionvalue 60 STRING PXEClient

dhcp server set optionvalue 66 STRING 134.138.205.18

dhcp server set optionvalue 67 STRING BStrap\X86pc\BStrap.0

 

If we do a test run the PXE-client server will time-out during PXE-boot with this message:

 

PXE-E55: ProxyDHCP service did not reply to request on port 4011

 

We can reach the BStrap\X86pc\BStrap.0 file in the RDP/PXE-server properly if we TFTP and “wget” the file manually from another Linux host.

 

If we specify another PXE-image to boot from we can deploy  a server successfully, for example “MenuOption130\x86pc\MenuOption130.0” boots the server into Linux automation. However, that breaks the automation in RDP and we have to press F12 every time to start deployment if the disk is 1st boot device, or if NIC is first boot device it always boots into automation even if nu job has been assigned in RDP.

 

We also made sure that no firewalls blocked any traffic between the PXE-server and the client, they are in the same subnet so no IP helper is required either.

The CMS has the Windows FW disabled.

 

***********

 

Nick replied:

 

****************

 

Have you manually set the PXE/DHCP server option in the PXE Configuration Manager “PXE Server” tab? There is an issue with RDP on W2K8R2 where it does not correctly find if DHCP is running locally or not. You may have to manually set it to “No DHCP server installed on PXE server”. I have seen this cause issues even when DHCP is not on the RDP server.

 

The screenshot below shows the screen

 

webpic147.jpg

 

 

*******************

 

Any other comments or suggestions?