BladeSystem Management Software

Incomplete Enclosure Temperature Value with OA 3.21

 
chuckk281
Trusted Contributor

Incomplete Enclosure Temperature Value with OA 3.21

Tobias had a customer question:

 

**************************

 

Hi,

 

A customer is using OA CLI for monitoring purposes. He noticed that the enclosure temperature output is incomplete with 3.21 due to missing thresholds. I checked this and we can see the same issue with other enclosures (c3000 and c7000).

 

Question: Have the enclosure temp thresholds been removed from the OA firmware by design or is it an issue?

 

Output with OA 3.10 (<3.2x)

C3000OA1> show enclosure temp

 

Locale                         Bay #     TempStatus      Temp    Caution   Critical

----------------------        -----        -----------              --------        -------   --------

Enclosure                                          OK             21C/ 69F    75C       80C

Onboard Administrator    1             OK             21C/ 69F    75C       80C

Blade Bay                           1             N/A            18C/ 64F    38C       43C

Blade Bay                           2             N/A            19C/ 66F    38C       43C

Blade Bay                           3             N/A            18C/ 64F    40C       45C

Blade Bay                           4             N/A            18C/ 64F    38C       43C

Blade Bay                           6             N/A            21C/ 69F    42C       46C

Blade Bay                           8             N/A            19C/ 66F    38C       43C

Interconnect Module      1   OK               ----      ---       ---

Interconnect Module      3   OK               ----      ---       ---

 

Output with OA 3.21

C3000OA1> show enclosure temp

 

Locale                                Bay # Temp Status      Temp    Caution   Critical

----------------------                 -----       -----------           --------      -------      --------

Enclosure                             N/A                             21C/ 69F    ---       ---

Onboard Administrator          1           OK             21C/ 69F    75C       80C

Blade Bay                                 1           N/A            18C/ 64F    38C       43C

Blade Bay                                 2           N/A            19C/ 66F    38C       43C

Blade Bay                                 3           N/A            18C/ 64F    40C       45C

Blade Bay                                 4           N/A            19C/ 66F    38C       43C

Blade Bay                                 6           N/A            21C/ 69F    42C       46C

Blade Bay                                 8           N/A            19C/ 66F    38C       43C

Interconnect Module      1   OK               ----      ---       ---

Interconnect Module      3   OK               ----      ---       ---

 

Best Regards

 

*****************

 

Monty answered:

 

*******************

 

The enclosure has no temperature thresholds, this display in the OA CLI was changed to eliminate confusion.

 

This change did not involve any change in OA Thermal Logic – we just removed the confusing display of enclosure temperature thresholds.

 

The OA CLI thresholds listed are actually only for the OA module itself, and not used in Thermal Logic.

 

In fact all the temperature thresholds reported by the OA are not used in Thermal Logic, they are just being reported for convenience.

 

*******************

 

Thoughts? Comments?