BladeSystem Management Software

Re: Question: Confusion Over Onboard Administrator & Virtual Connect Firmware Streams

 
KailahG
HPE Pro

Question: Confusion Over Onboard Administrator & Virtual Connect Firmware Streams

Howdy! 

 

I hope everyone had a great Fourth of July weekend This question came up on Friday, so we'll start the week off with this! 

 

Steve asked:

 

**************************

 

Can someone clarify what the latest OA (Onboard Administrator) & VC (Virtual Connect) versions are as there is a confusing picture -

 

OA -

 

Version:4.23 (19 Jun 2015)

Version:4.40 (31 Mar 2015)

 

The release notes say 4.23 has replaced 4.20, but the release history now appears to show 4.23 as the latest OA version?!?

 

Under what circumstances should 4.23 be used instead of 4.40?

 

VC -

 

Version:3.62 (8 Jun 2015)

Version:4.41 (18 Mar 2015)

 

As far as I know, 3.62 is primarily for the older modules (VC-ENET…) but it is now showing as the latest. Customers ‘updating’ from 4.x would lose all the features introduced since 3.70 (although with a ‘force’ option they may get it to work!).

 

*************************

 

There were quite a few good responses; below, Grant gives full coverage plus a great resource link for future reference:

 

*************************

 

OA 4.23 & VC 4.21 are currently the last versions to support any  G1-G5 blade up to and including Gen8 Blades in an enclosure.

 

OA 4.23 & VC 4.21 are currently the last versions to support any BL860 /BL870 Generation 1 Blade in an enclosure.

 

OA 4.40 & VC 4.41 are currently the latest versions that support any G6 Blade up to and including Gen9 Blades in an enclosure.

 

OA 4.40 & VC 4.41 are currently the last versions to support any  BL860 /BL870  i2 or i4 Blade in an enclosure.

 

(any b version added on to a firmware version means the firmware installer has been updated, however the firmware is still the same)

I.e. Virtual Connect 4.21b – the vcsu (Virtual Connect Support Utility) was updated in the zip bundled with the 4.21 Virtual Connect firmware

 

Documented here http://h41302.www4.hp.com/km/saw/view.do?docId=mmr_kc-0100204

 

Regards Grant

 

***************************

 

Additionally, here is another good answer specifically addressing the Onboard Administrator from Gururaj:

 

***************************

 

 

Hi Steve,

 

To clarify on OA 4.40 and OA 4.23.,   OA 4.40 is the latest  release.

 

OA 4.23 was released to address the following.

 

Issue description and fix:

HP Onboard Administrator- OA Running Firmware Version Earlier than 4.30 Cannot run

RIBCL Scripts on below versions of iLO.

  • HP Integrated Lights-Out 2 (iLO 2) Firmware Version 2.27 (or Later)
  • HP Integrated Lights-Out 3 (iLO 3) Firmware Version 1.82 (or Later)
  • HP Integrated Lights-Out 4 (iLO 4) Firmware Version 2.03 (or Later)

 

The iLO versions mentioned above disabled support for SSLv3 to address Poodle vulnerability

 

OA 4.23 version is intended for customers who continue to use G1-G5 blades.

 

Hope this helps.

 

Regards

Gururaj

 

**************************

 

Thoughts or comments?

 

1 REPLY 1

Re: Question: Confusion Over Onboard Administrator & Virtual Connect Firmware Streams

This info is exactly waht i was looking for. 

Latest OA and VC Firmware for G1-G5 blades.

 

Thanks

 

edit - Heres the link for the 4,23 OA Firmware

http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_47fded5dbf0a43fd91c385b45d