BladeSystem Management Software

Service Pack for ProLiant (SPP)2012.10 / cp018270.exe not installing

 
chuckk281
Trusted Contributor

Service Pack for ProLiant (SPP)2012.10 / cp018270.exe not installing

Hussain was having an update problem with Service Pack for ProLiant 2012.10.0:

 

*******************

 

I am using SPP2012.10 to update BL620c G7 servers to prepare them for MOE 7.1 U2 Matrix.

The servers are already in production running Hyper-V R2 and the servers have been upgraded before with an earlier version of SPP (probably 2012.06).

 

My problem is that when I use SPP2012.10 there is 1 component which will fail to update which is cp018270.exe (FCoE Windows Driver).

I found an advisory that explains the same symptoms and says that this is fixed in SPP2012.08.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03581886&lang=en&cc=us&taskId=101&prodSeriesId=4268686&prodTypeId=3709945

 

However, I’m already using a newer version SPP2012.10 which includes the same hotfix.

 

Anyone knows how to resolve this?

 

**************

 

Comment from Eric:

 

***************

 

I ran into a very similar issue just the other day.  The SPP2012.10 wouldn’t install the Gen8 1Gb Broadband NIC driver (among others).  If I ran the cpxxxxx.exe executable manually it gave an error about the patch not being for my OS.  I ended up just using the SPP2012.08 to install the missing drivers.

 

It looks to me like there’s a packaging issue with the 2012.10 package and it’s using the wrong executables for Windows 2008 R2.

 

***************

 

Reply from Hussain:

 

***************

 

The issue is resolved now.

We had a few network connections disabled on the OS side. This was causing the upgrade to fail.

This wasn’t mentioned anywhere in the logs.

After we enabled the disabled adapters, the component cp018270.exe upgraded successfully.

 

*************

 

Comments or questions?