BladeSystem Management Software

Re: rsadmin auth -activeDirectory error

 
wlchoo
New Member

rsadmin auth -activeDirectory error

Hi,

I'm setting up IRS active directory auth (rsadmin auth -activeDirectory) in Windows Server 2019, however I'm getting the following errors:

Exception : Could not find Active Directory during DNS look up. Please check the Domain name entered and try again.

I'm stucked and can't proceed with further configuration. Any suggestions are welcome.  

Thanks & Regards

 

3 REPLIES 3
ksram
HPE Pro

Re: rsadmin auth -activeDirectory error

Hi,

Good day!

May we please know if you have tried any steps and what is the current status.

Also do confirm if the DNS IP is pingable and if on same Network.

Thank you

RamKS


I work for HPE

Accept or Kudo

mgearhart
New Member

Re: rsadmin auth -activeDirectory error

I'm expericing the same issue when attempting to switch to Active Directory, using the command "rsadmin auth -activeDirectory":

"Exception : Could not find Active Directory during DNS look up. Please check the Domain name entered and try again."

I'm able to ping the basedn from the node and confirmed AD and the  node I am attempting to connect from are on the same network.

Thanks for the assistance,

-Michael

Olvi_1
Frequent Advisor

Re: rsadmin auth -activeDirectory error

Hi!

"Nice" to know that others have same issue. Our IRS installation is over two years old but abouth month ago I noticed that I cannot login anymore.

Today I had finally time to investigate this. Looking at logfile (C:\ProgramData\HP\RS\LOG\hprs-<date>.log) it seems to be some certificate issue when running rsadmin auth -activeDirectory command:

15 Jul 2021 13:39:36.050 [Thread-5] ERROR c.h.u.accounts.IRSAccountInfoManager - Certificate cannot be validated against a trusted root CA. Exception:(Illegal given domain name: <DOMAINCONTROLLER>.)
15 Jul 2021 13:39:36.097 CLIInterpreter[CLI] ERROR c.h.u.accounts.IRSAccountInfoManager - Certificate cannot be validated against a trusted root CA. Exception:(Illegal given domain name: <DOMAINCONTROLLER>.)
15 Jul 2021 13:39:36.112 CLIInterpreter[CLI] INFO com.hp.uca.auth.UcaLdap - Could not log into LDAP server using SSL. Trying to use non-SSL connections

 

Keeping story short, after few hours of "head to the keyboard" I was managed to get login working again with following command:

rsadmin auth -activeDirectory -server "<DOMAINCONTROLLER>" -ssloff -port 389 -domain "<DOMAIN>" -basedn "DC=examble,DC=com" -admindn "CN=IRS_Admins,OU=Groups,DC=examble,DC=com" -operdn

Don't know root cause what has happend and honestly don't care since now login works. Hopefully this helps somehow.