BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

SOLVED
Go to solution
Kennedy G. Doss
Regular Advisor

BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

HP-UX SAs:

This is the third BL890c server that I am having the same issue with, in the past 3 months. I do not get an output with the machine serial number from the OS with either getconf or from the machinfo commands. Has anybody else encountered this issue? Just curious....

The solution of course is to have a HP CE come onsite and run OEM / proprietary commands that requires a downtime.

 

I was just wondering if this is a known issue - or just a co-incidence that this is happening only at our site.

 

From the iLO / MP Prompt, I don't get the serial numbers when I use the OEMSYSSET. However, the SYSSET command displays the Serial Number accurately.  

 

CM:hpiLO-> OEMSYSSET

 

OEMSYSSET
Current System Information Parameters:
Manufacturer (manuf) : HP
Secondary Manufacturer : HP
Product Name (prodname) : Uninitialized
Secondary Product Name : Uninitialized
Serial number (serial) : Uninitialized
Secondary Serial Number : Uninitialized

 

 

CM:hpiLO-> sysset


SYSSET
Current System Information Parameters:
Manufacturer : HP
Product Name (prodname) : Integrity BL890c i4
Secondary Product Name : Integrity BL890c i4
Product Number (prodnum) : AM398A
Secondary Product Number : AM398A
Serial number (serial) : xxxxxxxxxx
Secondary Serial Number : xxxxxxxxxx

 

 

P.S. This thread has been moved from HP BladeSystem to HP BladeSystem Server Blades. Also for your secutiry, we have removed serial number from your post. That is information you probably do not want to make publicly available. - HP Forum Moderator

5 REPLIES
Torsten.
Acclaimed Contributor

Re: BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

As far as I know this sysset vs. oemsysset output is normal.

 

With sysset values populated "machinfo" should show the values.

 

How does the machinfo output look like?

 

There were several patches for machinfo, maybe one is related?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Kennedy G. Doss
Regular Advisor

Re: BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

Thanks for your prompt response, Torsten. I have an open call with Mission Critical Support and we have a CE on his way to fix this. I am assuming that this is not related to a patch - I am sure the Backend Support person would've adviced that as a first option. (For the other two servers that I mentioned earlier, too we did not have to patch the server to resolve the issue. I am just finding it strange that we had three servers with identical issues in a short span. )

 

Your response is very much appreciated. Thanks.

 

The output of machinfo:

Platform info:
Model: "ia64"
Machine ID number: 725249b1-c530-11e2-a8b1-cba88d7f51a4
Machine serial number:

 

 

The output of getconf:

# getconf MACHINE_SERIAL


:#

Kennedy G. Doss
Regular Advisor
Solution

Re: BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

The issue was resolved by the CE who had to visit on-site. He logged into the console and ran a few commands and had me reboot the servers. And the serial number magically appeared when I ran get_conf command. The issue is probably all the three servers were upgraded from a BL870 to BL890. Looks like the Hardware Engineer who was responsible for the conversion had missed a step.

Kennedy G. Doss
Regular Advisor

Re: BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

Moderator:


The Serial Number Posted in my original posting was a Fictitious one :) FYI.

Robert_Jewell
Honored Contributor

Re: BL890c - getconf MACHINE_SERIAL or machinfo not pulling out Serial Number of the Server

id bet it was the Blade Link module.  When upgrading, those are repalced and would have been new, which means cleared of values.   usually, when the system boots you get message indicating such.  Maybe the data just didnt copy correctly?

 

Anyway, just my 3.8c  (cost adjusted for inflation).

 

-Bob

----------------
Was this helpful? Like this post by giving me a thumbs up below!