HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem Server Blades
Showing results for 
Search instead for 
Did you mean: 

C3000 + BL460c G1 + P2000 G3 last firmware + HBA Emulex HP LP1105e + Windows 2012 : BOOT PROBLEM !

R. Verissimo
Occasional Contributor

C3000 + BL460c G1 + P2000 G3 last firmware + HBA Emulex HP LP1105e + Windows 2012 : BOOT PROBLEM !

Hello, after a reboot two weeks ago of 6 Windows 2012 nodes of our cluster (following a datacenter scram / loss of power)

The nodes were stuck at early boot phase.


i tried to disable emulex driver in the registry : same problem.

i tried to boot on WinPE 4.0 with only the smart array driver : same problem.


So my deduction is that some kind of core windows driver is the culprit, not the emulex driver per se.


When plugging out the emulex HBA mezzanine, system boots OK.


I tried to enable the boot drivers to show with the following commands :


bcdedit /store <path to BCD> /set sos on

bcdedit /store <path to BCD> /set {default} bootmenupolicy legacy


on the production Windows 2012 and WinPE 4.0 but it does not show the drivers loading


The write to log file (ntbtlog.txt) F8 boot option was tried too without success.


How could i find what driver is messing with the HBA and boot process ?


We managed to shift the production to ISCSI but the problem is still very sensitive.


Will open a case with HP and Microsoft tomorrow and see what happens.

This issue is strange and should be investigated...


So all ideas welcome !


R. Verissimo
Occasional Contributor

Re: C3000 + BL460c G1 + P2000 G3 last firmware + HBA Emulex HP LP1105e + Windows 2012 : BOOT PROBLEM

Seems we managed to resolve the problem. A case was opened at Microsoft.


In our steps to generate a memory dump,  we resolved the problem by reconfiguring the pagefile.


here is how :


How to reproduce the problem  / conditions for the problem to arise :


  • Bl460c G1 with Smart Array E200i (64MB)
  • Presence of a mezzanine type 2 card (FC HBA)
  • More than one Smart Array local RAID LUN (in our case there was two LUNS)
  • Swap (pagefile) is set up on one of the LUN or both


Description :


20 seconds into the Windows boot, boot process freezes and the local hard disks start blinking synchronously every 1 second.


Analysis :


the smart array and FC HBA are probably involved in a mutual lock,  and system seem to lose acesss to the smart array local RAID luns during the boot when there is a pagefile on the local LUNs


Workarounds :


  • Remove all pagefiles from the local LUNs, the best is to try first without any pagefile
  • Reconfigure RAID to only one local LUN, then it can host a pagefile


Follow-up :


Will see with MS if it could be a QFE that initiated the problem.


have a nice day.