Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

Using 16GB Sandisk USB drives for VMware

chuckk281
Trusted Contributor

Using 16GB Sandisk USB drives for VMware

Dana was having issues with a customer installation:

 

***************

 

I was doing a POC with a customer and the customer had install ESXi 5.5 on an internal 16GB sandisk USB of a BL460c Gen8. The 460c Gen8 would not boot. It would bypass the USB drive even though we made it first in the boot order. It would also not boot from the boot menu when specifically selected. We repeated the same process with an 8GB usb and it booted every time. The blade also boot to an internal 16GB SD card successfully. I have searched the user guides and manuals but cannot find a reasone why the 16GB USB on the internal would not work. Any thoughts or reasons? Thanks in advance for any help! Customer is running sd card now so all is good there, I am just curious why a 16GB USB would not work.

 

Thanks!

 

*************

 

Reply from Amrit:

 

*************

 

32GB supports Linux and Windows. It doesn’t support VMware. Till 8GB VMware works fine.

Refer following:-

https://h20564.www2.hp.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c03963231

http://h20195.www2.hp.com/v2/GetDocument.aspx?docname=c04123175&doctype=quickspecs&doclang=EN_US&searchquery=&cc=lamerica_nsc_carib&lc=en

 

And you should be using HP SD cards for support purposes.

 

**************

 

Comments or questions?

 

2 REPLIES
scharchouf
HPE Pro

Re: Using 16GB Sandisk USB drives for VMware

HP Flash Media kits optimized for VMWare Hypervisors:

 

  • HP 2GB USB Flash Media Drive Key Kit
  • HP 8GB USB Enterprise Mainstream Flash Media Drive Key Kit
  • HP 4GB SD Enterprise Performance Flash Media Kit
  • HP 4GB microSD Enterprise Performance Flash Media Kit
  • HP 8GB SD Enterprise Mainstream Flash Media Kit
  • HP 8GB microSD Enterprise Mainstream Flash Media Kit

Parts for your server are :

 

  • HP 2GB USB Flash media drive key kit (PN: 608447-B21)
  • HP 4GB microSD Enterprise performance flash media kit (PN: 647444-B21)
  • HP 8GB microSD Enterprise mainstream flash media kit (PN: 726116-B21)
  • HP 32GB microSD Enterprise mainstream flash media kit (PN: 700139-B21)
I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

chuckk281
Trusted Contributor

Re: Using 16GB Sandisk USB drives for VMware

Some info from Dan:

 

**************

 

So I happened to have a SanDisk “Cruzer Blade” 16GB drive sitting here unopened.

 

I popped it into the BL460c Gen8 in the garage and was able to install 5.5 U1 (1623387) just fine.

But on reboot, it did not boot from the USB drive.  Not entirely surprising though as I didn’t tweak the BIOS at all.

 

Now I’m in “Standard Boot Order (IPL) and I moved USB DriveKey to position 3 right behind CD and Floppy.

Nope, didn’t work and it’s trying to PXE boot now.

 

But I recall others on this PDL saying before you have to set the USB Boot order to match the device you want or it won’t boot to it.

So back into the BIOS we go. 

System Options \ USB Options \ Removable Flash Media Boot Sequence (this is like the USB/SD Sub Boot Order, just like the “Boot Controller Order” right below IPL is a Sub menu for “Hard Drive C:” in the main IPL).

Ahh, ok, mine is set to boot from SD Card.

Changing it to “Internal DriveKeys First”.

As I’m backing out, double check that “USB Boot Support” is Enabled.

Save Changes and Reboot.

 

Swing and a Miss again.

Trying to PXE Boot.

ESC to Cancel NIC 1

ESC to Cancel NIC 2

F11 twice

Option 3 for USB DriveKey boot.

Attempting Boot From NIC

Grrrrr

 

So I’m having the same problem you/your customer are.

 

I remember way back for a Discover 2011 Lab I did on this subject I used some random sketchy 4GB USB I had in the bottom of my backpack in a DL360 G7 and it worked just fine.

And I know this machine works with MicroSD as I have a 32GB Sony I was using to boot ESXi that I removed in order to test this for you.

 

Going to try an older build of 5.1 or 5.0

Then I’ll go swap the 16GB USB for a different model and try again.

 

--------------------------

 

So it seems to be a SanDisk thing.

 

I installed 5.5, 5.1 and 5.0 and played with all the Boot Settings and OneTime Boot to DriveKey I could handle.

Nothing worked.

 

Finally went out and swapped the SanDisk with a Patriot brand (Axle series), also 16GB, and it booted just fine on the first try.

This Patriot Axle 16GB was formerly my MP3 drive for use in the car for the last year and was like $10 when I bought it.

So it’s nothing special and has had plenty of use.