BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

4G Qlogic on 8G Virtual Connect problem

chuckk281
Trusted Contributor

4G Qlogic on 8G Virtual Connect problem

Esa needed help with a SAN connectivity problem:

 

**********************

 

Hi,

Having connectivity problem with:

Blade 460 G6 + QMH2462 + 8/20Virtual Connect + 8/24 Brocade SAN swich

 

If all as factory default:

Qlogic can make fabric login to Brocade switch BUT it does not see any EVA (4400) ports.

No EVA ports -> no Boot disk from EVA L

 

If setting outside Virtual Connect port speed as fixed 4G:

Qlogic can see EVA ports and disks, and can successfully boot from san.

 

**********************

 

Alex got involved:

 

**************************

 

Esa,

 

I think we have seen more and more issues similar to what you are experiencing when connecting at 8Gb and having issues, while having much better success when speed was fixed to 4Gb. Based on information provided by HP engineering and Brocade, this resolution of these issues was introduced with Brocade FOS versions v6.3.1 or v6.4.x. If option “mode 3” is not selected for the portCfgFillWord in Brocade SANs, we can’t guarantee 8Gb connectivity with VC 8Gb 20-port FC modules. Today, by default, Brocade switches are still using ”option 0” or “mode 0” (idle/idle).

 

Please see below they description of the command and each option mode. Customer would need to set option “Mode 3” when attaching to VC-FC 20-port modules.

 

Alex

 

 

***********

The portCfgFillWord command, applicable to 8G-capable ports, has been enhanced with FOS v6.3.1 and v6.4 to provide two new configuration options (Modes 2 and 3). The available settings include:

 

Usage: portCfgFillWord <PortNumber>  <Mode>

Mode: 0/-idle-idle   - IDLE in Link Init, IDLE as fill word (default)

               1/-arbff-arbff - ARBFF in Link Init, ARBFF as fill word

               2/-idle-arbff  - IDLE  in Link Init, ARBFF as fill word (SW)

               3/-aa-then-ia  - If ARBFF/ARBFF failed, then do IDLE/ARBFF

 

Although this setting only affects devices logged in at 8G, changing the mode is disruptive regardless of the speed the port is operating at. The setting is retained and applied any time an 8G device logs in. Upgrades to FOS v6.3.1 or v6.4 from prior releases supporting only modes 0 and 1 will not change the existing setting, but switches or ports reset to factory defaults with FOS v6.3.1 or v6.4 will be configured to Mode 0 by default. The default setting on new units may vary by vendor. Please use portcfgshow CLI to view the current portcfgfillword status for that port.

 

Modes 2 and 3 are compliant with FC-FS-3 specifications (standards specify the IDLE/ARBF behavior of Mode 2 which is used by Mode 3 if ARBF/ARBF fails after 3 attempts). For most environments, Brocade recommends using Mode 3, as it provides more flexibility and compatibility with a wide range of devices. In the event that the default setting or Mode 3 does not work with a particular device, contact your switch vendor for further assistance.

 

***********

 

And we got a Brocade document from Jason:

 

**********************

 

See the attached Brocade document.

 

**********************

 

Any other comments and suggestions? Are you seeing 4Gb and 8Gb SAN connectivity issues.

1 REPLY
Richard Stasior
Occasional Visitor

Re: 4G Qlogic on 8G Virtual Connect problem

The QLogic QLE2560-CK adapters take advantage of QLogic StarPower technology, ensuring power efficiency. QLogic StarPower technology offers dynamic and adaptive power management features such as power and bandwidth optimized intelligent PCI Express link training, low-power switching power supplies, and thermally efficient layout requiring lower airflows.  The QLE2560-CK adapters are backward compatible with 4Gb and 2Gb speeds. RICOM's Qlogic engineers can assist with this issue