BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Enclosure firmware update to v3.75

 
chuckk281
Trusted Contributor

Enclosure firmware update to v3.75

Ravi was looking to do some updates and had some questions:

 

******************

 

I have C7000 enclosure in customer environment and 4 HP VC Flex Fabric 10Gb/24-Port Modules with 8 BL460C G7 servers.

 

In some reason we are unable to perform a blade server firmware/driver update for one blade. Can we proceed an enclosure firmware update without updating firmware of one blade server.

 

Will it cause any issue if I proceed enclosure firmware update without updating one blade firmware.

 

Current version of OA 3.32 and VC 3.30 .

 

*****************

 

Reply from Lawrence:

 

**************

 

There is not sufficient information from your email to be able to comment with absolute certainty whether one blade not being updated will cause issues. 

 

Generally speaking, unless there is a specific firmware version required for the environment (e.g. http://h20564.www2.hp.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c02623029), the firmware components for the individual blades can vary significantly for each individual blade without causing issues.  I have seen customer enclosures where the blades have various BIOS versions, various iLO versions, various PMC versions, etc. and they are not experiencing issues from having inconsistent baselines.  Whilst not ideal from a support perspective due to the lack of uniformity, it has not been an issue for them.

 

Can I ask – what is the specific reason for this particular firmware update activity to your customer’s environment? 

 

Depending on the reason for the update, if that one blade is not updated, it might only mean that the one blade alone would not receive the benefit of the update, which is typically a bug fix.  But in extreme cases, just one blade not being updated can still cause serious issues to the whole environment.  One example is HDS and XP arrays are not tolerant of certain Emulex CNA firmware versions if using FCoE and one single server can cause issues to the storage environment, which subsequently affects other servers connected to that same storage device.

 

***********

 

From Ravi:

 

*************

 

My requirements is to accommodate gen 8 blades in to enclosure empty bays.

 

**************

 

And back from Lawrence:

 

*************

 

In that case, if the existing G7 blades are running fine, you don’t need to update them just to put the Gen8 servers in to the same enclosure.  This is because there are no firmware dependencies between the blade servers within an enclosure.

  

The Gen8 servers will require the OA to be updated to 3.50 at a very minimum and VC to 3.51 as a minimum, as you know.

 

webpic213.jpg

 

*****************

 

Comments?