HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Flex 10 VC Corrupt certiifcate cannot use web interface

 
Nick Eoannidis
Occasional Advisor

Flex 10 VC Corrupt certiifcate cannot use web interface

Hi All, Does anyone know how to do a true factory reset on the hp flex 10 VC modules? I uploaded a certificate following the instructions (i successfully did it with the OA's worked fine!) and it has killed the Virtual Connect Manager web interface - i can only telnet into the Flex-10 vc's and there is no way to remove the dodgy cert! Ive tried resetting the OA and the enclosure, also deleted the vc domain config from telnet and rebooted everything again - same problem cannot get to the web int. Im really worried that my redundant flex10s are bricked and will have to go HP warranty case.
6 REPLIES
Xavier Perez
Occasional Visitor

Flex 10 VC Corrupt certiifcate cannot use web interface

Hello, Did you check the firmware compatibility? http://h18000.www1.hp.com/products/blades/components/vc-compmatrix.html Xav
Nick Eoannidis
Occasional Advisor

Flex 10 VC Corrupt certiifcate cannot use web interface

Hi all, If anyone has this problem - you can solve it by regenerating the certificate signing request through telnet via the onboard administrator. Sign the cert with your ca MAKE SURE YOU USE A WEB SERVER certificate. Upload the ca to the VC via telnet and it will apply. im very glad that this could be done via telnet and my flex's are not bricked regards Nick
strategery
Occasional Visitor

Flex 10 VC Corrupt certiifcate cannot use web interface

I have the same issue, but each time I try to load the new cert via load ssl-certificate, I get Error:request failed.
strategery
Occasional Visitor

Flex 10 VC Corrupt certiifcate cannot use web interface

More information... I did use Web Server as the template when completing the CA request. The same process worked fine with the OA.
Nick Eoannidis
Occasional Advisor

Flex 10 VC Corrupt certiifcate cannot use web interface

hey strategery, did you get it to work by creating a webserver cert and uploading via the OA telnet commands? i know how much of a pain this was so if you need help let me know. regards, Nick
strategery
Occasional Visitor

Flex 10 VC Corrupt certiifcate cannot use web interface

No, that's what I tried. I also SSH'd to the VC in bay 1. Here are the commands I entered with IP and account info modified: ->save ssl-csr address=ftp://anonymous:password@192.168.1.111 SUCCESS: SSL Certificate Signing Request (CSR) generated and transferred ->load ssl-certificate address=ftp://anonymous:password@192.168.1.111 filename=ssl.crt ERROR: Request Failed