BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Flex-10 and VPC - vpc port channel mis-config

Eric D Christensen
Occasional Contributor

Flex-10 and VPC - vpc port channel mis-config

OK.... I think I'm missing something here.... I can'r get VPC on a pari of Nexus 5500s to play nice with a Shared Uplink froma  pair of Flex-10 modules. Topology is very simple:

 

Single c7000 chassis with a pari of Flex-10 modules in slote a 1 & 2.

Two Cisco 5500 chassis vpc peer linked.

One uplink port from Flex-10 slot 1 port x5 to Nexus 1 port eth1/10, one from Flex-10 slot 2 port x5 to Nexus 2 port eth 1/10.

Port channel 110 define with vpc configured between the two nexus ports.

Probelm is that one nexus port will come up on vpc. The other reports:

    110    Po110       up     failed      vpc port channel           -
                                      mis-config due to vpc
                                      links in the 2 switches
                                      connected to different
                                      partners

 

Yet the Flex-10 modules seem to think it's all good:

 

 

vpc.png


I've readt everything i can and as fara s I can tell the *should* be a valid config. Am I msunderstanding something here?

I haven't tested this, but I'm reasonably sure this won't fail over correctly.

 

 

 

 

 

2 REPLIES
Psychonaut
Respected Contributor

Re: Flex-10 and VPC - vpc port channel mis-config

Eric D Christensen
Occasional Contributor

Re: Flex-10 and VPC - vpc port channel mis-config

Ugh! Rookie mistake on my part. I incorrectly set up the vpc across connections to two different Flex-10 modules. I can't believe that I missed that!

 

I'm off to re-cable the links correctly which I'm sure will resolve the issue.

 

Doh!!!!