HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Help with VC active- active config

 
akash1980
Advisor

Help with VC active- active config

Guys, I am trying to configure VC FFs with two Ethernet ports on each module, 2 modules. I am trying to configure active- active at VC level and redundancy at OS NIC level.

Intended config is as follows.

 

Trunk- 1 – B1X6, B1X7

Trunk 2 – B2X6, B2X7

 

And Uplink connectivity is as follows. These are VPC like switches.

 

B1X6 – Sw1Port1

B1X7 – sw2 Port 1

B2X6- SW1 port 2

B2X7 – sw2 port 2

 

Issue is, when creating two trunks as active -active, it’s showing two links as active and remaining two are as Standby. Can someone advise why it is so and how to configure them as active- active?

 

Another question is, if I need to add 1 more uplink connection to each VC, what is the suggested mapping to the uplink switches?

2 REPLIES
Casper42
Trusted Contributor

Re: Help with VC active- active config

You have it configured correctly on the VC side best I can tell.

If you truly have a vPC feature in your switches (IRF, Virtual Chassis, MST, etc) then you can take a link from each upstream switch and trunk them together as long as they terminate on the same VC module.

You do of course need to make sure you create 2 different LAG/BAG/PortChannel type interfaces on the upstream switches though. You cannot add all 4 ports to the same LAG.

Adding more links - doesn't really matter since it will be odd/unbalanced. If your upstream switches were HPN running Comware, you could have 3 upstream switches in a single IRF cluster and that would map quite nicely, but other vendors seem to limit things to 2 switches virtualized as 1.


As far as your problem.
1) Give it at least 2 minutes after configuring the SUS and then check again. LACP is not always as fast I as I think it should be and often times things come up in Standby mode and then flip to proper settings a minute or so in.

2) Use the bottom left corner of the VC GUI called Hardware, go to Interconnect bays and then Bay 2. If you are on VC 3.70 you then need to go to the Uplinks tab, older versions just scroll down a bit. There is a chart that shows the Ethernet uplinks, LAG IDs and if you have LLDP enabled upstream, will even show you the upstream switch MAC and Port information.
Anything in there look wrong? Does this match the LACP members you configured (wrong port used maybe?)
ACHCHGUY
Frequent Advisor

Re: Help with VC active- active config

We have this configuration.

Using the SUS.

 

Make sure the connection mode is auto.

 

DO not use tunnel mode as it wont work, must use SUS. We had HP here for half a day working on same issue.

 

the downside is the number of vlans you can support. we are a cloud Service provider and have found the limitation of the sus not to be an issue so happy to stick with it.

 

In tunnel mode you can only basically have one uplink from each VC we were told  and loose some functionality hence the SUS instead.

 

we have 2 x 10 GB ethernet comming out of each blade enclosure in active active and works well.

 

Get it working with one uplink out of each vc first.

 

Then you need to create ethernet networks for each vlan ie vlan_100_A and vlan_100_B assign A to sus 1 and B to SUS 2.

 

When creating the Server profile under the ethernet adapter stuff use the multiple networks option.

 

I hope I have understood your issue and helped in some way.