BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Incompatibility issue between VC Enet and VC FC

SOLVED
Go to solution
d0kt0r
Frequent Advisor

Incompatibility issue between VC Enet and VC FC

Hi guys,

 

We bought at the end of last week the module 447047-B21.

 

OA Firmware is actually 3.21, and VC Firmware is actually 3.51 on the VCM on the last posted P/N.

 

The problem is that the FC Module : 409513-B21 (VC FC 4GB)  with a FW revision a bit old ( 1.40 ) it says incompatible on the VCM, and can't create any SAN Fabrics.

 

Any recomendation?.

 

I would appreciate any bit of help, as Im in a serious situation :(

 

Thanks a lot guys,

 

Dan.

4 REPLIES
d0kt0r
Frequent Advisor

Re: Incompatibility issue between VC Enet and VC FC

Hmmm,

 

On system log says this :

 

[FC:enc0:iobay3:4010:Info] FC Module state OK : Component fully operational, Previous: FC Module state UNKNOWN
2013-10-11T21:53:25+02:00 VCEFTW2832006W vcmd: [FC:enc0:iobay3:4014:Major] FC Module state INCOMPATIBLE : Component does not match configuration, Previous: FC Module state OK

 

[ENET:enc0:iobay3:3014:Major] Enet Module state INCOMPATIBLE : Firmware mismatch: Current: [1.40], Supported: [1.43]. Module will be marked as INCOMPATIBLE.

 

Should I update the module to 1.43? And where I could find it?

 

Thanks guys!

JimTonic
Advisor

Re: Incompatibility issue between VC Enet and VC FC

Generally speaking it is a good idea to upgrade both OA and the modules to the latest firmware versions.

 

Latest available firmware version OBA: 3.75

Latest available firmware version VC: 4.01

 

Thet latest SPP version 2013.09.0(B) - including OBA and VC - can be found/downloaded from hp:

http://h18000.www1.hp.com/products/servers/service_packs/en/index.html

 

However before updating make yourself familiar with the hp release notes, especially with the 4.01 release notes for VC:

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c03801912/c03801912.pdf

 

Depending on your environment and current configuration there can be issues and dependencies that prevent you from upgrading the firmware, so do your homework, and take the possible consequences special to your situation into account.

 

In an ideal world your would have a test-environment with the same hardware and firmware versions. Anyway its always good to have a backup, so backup your VC config and stick to the instructions in the hp relases notes.

Casper42
Trusted Contributor
Solution

Re: Incompatibility issue between VC Enet and VC FC

FC Versions are not the same as VC Enet versions. So 1.40 isn't THAT old.

Now that being said, if you want to get the "matching" VC FC firmware all you need to do is download the latest VCSU which is used to upgrade Virtual Connect.

Then download the VC Enet firmware that matches what you ARE ALREADY RUNNING.
So in your case its VC 3.51

Run VCSU and point it at the 3.51 BIN file.
After you get through the series of questions and it has a chance to scan the running firmware, you should get a screen that shows what versions you have and what versions will be upgraded to. The Ethernet modules should show that they won't change and the FC versions will show they are going to be upgraded to 1.43.


If you want to take some downtime and get everything upgraded, upgrade VC to 3.60 because that is the last version that supports the 1/10 module you listed the Part Number for.

Will require the Ethernet modules be rebooted but it will only do them 1 at a time so if your networking is setup for proper redundancy, you should not have any major outage. Though I would still do this after hours during a maintenance window.

Hope that helps,
Casper
d0kt0r
Frequent Advisor

Re: Incompatibility issue between VC Enet and VC FC

Awesome answer Casper.

 

Exactly my problem.

 

Thanks!