BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Just some interesting info: Cisco Native VLAN Default is 1

 
chuckk281
Trusted Contributor

Just some interesting info: Cisco Native VLAN Default is 1

Dan was sharing some good info about the settings on Cisco Switches and working with Virtual Connect modes:

 

**************

 

So this caused one of my customers (and me for not knowing) some heartache recently and I just wanted to share this tidbit for all the non-network people out there.

 

If you configure a Trunk Port on a Cisco switch (multiple VLANs to connect to our SUS in Virtual Connect)

AND

This Trunk port allows VLAN1 as one of the configured VLANS

               Example command: switchport trunk allowed vlan 1,5,9-11,14,17,67,100

AND

The matching Network in Virtual Connect for VLAN 1 is NOT configured for “Native” (Checkbox is Unchecked)

 

Then VLAN 1 on the VC inside might not work properly.

 

This is because the Cisco switch defaults to Native = VLAN 1 and if we don’t have Native on our side, we will essentially throw out all the inbound packets because they are untagged.

 

So the short version is watch out for VLAN 1 in Cisco environments unless the network team tells you it’s specifically NOT flagged as the Native VLAN.

 

If you wanted to be ahead of the game and will be doings hands on demo/POC, you would ask the server team or whoever gave you the list of VLANs they want inside the SUS to ask their network team if any of those VLANs are the Native VLAN.  In the example above, if 67 was the native VLAN, you would need 67 to be flagged Native on the VC side as well or that particular Network would not work properly instead of 1.

 

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/AccessTrunk.html#wp1206651

 

****************

 

Other comments or input?

1 REPLY
mc_rae
Occasional Advisor

Re: Just some interesting info: Cisco Native VLAN Default is 1

That was a very good hint, thanks

 

I ran into the same issue.