HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast address ranges with virtual connect

 
Michael Pye
Occasional Advisor

Multicast address ranges with virtual connect

We have built several Red Hat clusters on BL465 g7 blades, using the RHEL5 Cluster Suite software. The basic premise of thie cluster software is that the nodes contact each other using a private multicast  IP of 239.192.x.x. We have several blades on the cisco catalyst blade switch (not virtual connect) where this works fine.

 

But on VC Flex-10 modules, these ranges cannot be used, and the nodes never see each. If I change the multicast IP to 239.0.0.1, then the nodes can see each other again. This happens with or without IGMP snooping enabled in VC.

 

My suspicion is that virtual connect does not forward multicast packets for the 239.192.x.x multicast range. Can anyone comfirm if this is true or not, and why would it be the case if so ?

 

 

3 REPLIES
Hongjun Ma
Trusted Contributor

Re: Multicast address ranges with virtual connect

what's VC version? for earlier release with igmp snooping on, there were some issues.

 

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?locale=en_US&objectID=c02535509

 

I know you mentioned that you see the problem with or without IGMP snooping.

 

the address should work fine. I suggest you open an HP support case for further troubleshooting.

My VC blog: http://hongjunma.wordpress.com



Michael Pye
Occasional Advisor

Re: Multicast address ranges with virtual connect

Interesting advisory there, thanks for the response. I have one two-node cluster that both nodes use VC version is 3.30 , and another two-node cluster with 3.51 one node and 3.18 the other node. They all exhitbit this problem. Does sound like maybe a case for HP. There must be other vc users running red hat clusters that have this problem?

Hongjun Ma
Trusted Contributor

Re: Multicast address ranges with virtual connect

if you want to dig in further, try enable igmp snooping and do the following command for enc0:1 or end0:2(VC-1 or VC2). also, you can set up port monitoring on VC to sniff the traffic.

 

->show igmp-group enc0:1

===========================================

Port  Group IP Address  MAC Address       

===========================================

d6:c  224.224.224.224   01:00:5e:60:e0:e0 

d8:c  224.224.224.224   01:00:5e:60:e0:e0 

d9:c  224.224.224.224   01:00:5e:60:e0:e0 

d1:c  239.193.0.107     01:00:5e:41:00:6b 

d1:c  239.192.0.107     01:00:5e:40:00:6b 

d1:a  239.255.255.253   01:00:5e:7f:ff:fd 

d2:a  239.255.255.253   01:00:5e:7f:ff:fd 

My VC blog: http://hongjunma.wordpress.com