BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with 554FLB and Hitachi VSP

JoeMuldoon
Occasional Contributor

Problem with 554FLB and Hitachi VSP

Hi all,

 

I was wondering if anyone had come across an issue we're facing. We're in the middle of migrating from an Hitachi USPV to a VSP. Recently my VMware team has started using HP generation 8 blades with 554FLB converged network/fibre adapters. The problem is, according to HDS, the cards are sending bad data causing the VSP CHAs (front end fibre ports) to go offline. Here's exactly what HDS is saying:

 

""Due to Emulex 554FLB(647586-B21) being connected (not supported Converged Network Adapter), the VSP received frames it doesn't support.  CHK2 errors resulted and DMA went blocked.

The reason for the CHK2 errors is Tachyon adds incorrect UDT guarantee code if it receives frames with 4 byte boundary.
CHK2 errors will then be detected with the frames with the incorrect UDT when the frames are transferred from LR to CACHE."

 

We have about 10 of these new blades connected to our USPV without issue. I have both HP and HDS looking into it with blame being thrown in both directions. We're also using Cisco MDS 9513s running at 4.2 code.

 

Any help would be greatly appreciated!

 

Thanks,

Joe

muldoonj@gmail.com

6 REPLIES
Michael Leu
Honored Contributor

Re: Problem with 554FLB and Hitachi VSP

Wow, thanks for sharing this information. Sorry I can't help you, it must be really frustrating seeing the blame being passed around on such high-end tech.

 

Especially because HP resells the VSP as the P5900 and therefor should be interested in a fix. Strangely the Emluex 554FLB 647586-B21 is not listed in SPOCK it seems...

Hongjun Ma
Trusted Contributor

Re: Problem with 554FLB and Hitachi VSP

please reach out to your account team and HP support to open a support case for this.

 

Emulex(NC554 vendor) has identfied the similar issue with current firmware/driver and a new firmware/driver has been tested internally which fixed the problem.  The firmware version is 4.1.450.7. You'll need to get the internal firmware and the drivers along with it from HP support. This version should be available publicly some time soon, 

 

This is actually a CNA issue, not virtual connect issue.

My VC blog: http://hongjunma.wordpress.com



Lawrance Lee_1
Frequent Advisor

Re: Problem with 554FLB and Hitachi VSP

Slight correction here.

 

F/W 4.1.450.7 (which is part of Service Pack for Proliant 2012.06.0) is NOT the correct firmware version to go to.

 

 

The correct CNA f/w version is 4.1.450.16.

 

 

This new firmware version has only just been published last week.

 

You can download the offline updater ISO tool for this new firmware version here:

 

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=5215390&prodTypeId=3709945&prodSeriesId=5215389&swLang=8&taskId=135&swEnvOID=54

 

 

Every server that is connected to the XP/HDS array fitted with an NC551 or NC553 or NC554 controller must have the firmware updated - it only takes one server that is still on the old firmware to cause the array's CHA to block al  I/0, resulting in loss of storage to the hosts that are on that CHA.

 

Emulex f/w requires matching drivers, but in this case, just use the drivers that were designed for f/w 4.1.450.7 - these drivers will be compatible with f/w 4.1.450.16.

 

 

 

 

Cy Webit
Occasional Visitor

Re: Problem with 554FLB and Hitachi VSP

So perhaps dumb question, but on a system running ESXi 5. how do I find the firmware & driver version of the Emulex Network controller 554FLB?

 

didwenger
Occasional Advisor

Re: Problem with 554FLB and Hitachi VSP

@Cy Webit,

 

  1. Open your vSphere Client and select your ESXi host
  2. Browse to the "Hardware Status" tab
  3. Under the "Sensors" view, expand "Software Components"
  4. Look for "be2net device firmware" and "be2net driver", that's for Emulex 554FLB

There might be a powershell command that would allow you to retrieve the info for multiple hosts...I haven't looked for it.

 

Regards,

Did

Michael Leu
Honored Contributor

Re: Problem with 554FLB and Hitachi VSP

Just for reference here is the official Advisory:

 

Advisory: SPP HOT FIX - HP ProLiant Servers: HP Emulex Converged Network Adapters (CNAs) - Access May Be Lost to Attached HP XP P9500, XP24000, or XP20000 Disk Array Channel Adapters (CHAs) and XP Disk Array Storage

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c03711985